PDA

View Full Version : 1756-EWEB Cards


matger
January 23rd, 2007, 05:20 PM
Hello, this is my first post on this forum so i hope someone could give me a helping hand :)

I have 2 AB 1756-EWEB/A ethernet cards, one has firmware version 3.006 and one has version 4.003. The card with the earlier firmware works perfectly, but RSLinx sees the card with the newer firmware as an "unrecognized device".
I suspect that the problem is with the versions of RSLinx/Logix5000 that I am running (Linx = Classic Lite v. 2.5 Logix = v. 15) but my boss does not want this project to update to Logix v. 16 (thinks it still has bugs). I have tried using ControlFlash to bring the v.4 firmware back to v.3 but it ain't happening. Does anyone have any idea of what options I have?

jtn
January 23rd, 2007, 05:27 PM
Go here http://support.rockwellautomation.com/ControlFlash/ and look at the chart showing what hardware and what software/firmware will work together. I print this out every so often and carry it with me as I'm in a different place all the time working.

OkiePC
January 23rd, 2007, 06:20 PM
Another thing to get rid of the unrecognized device warning in RSLinx: Get the latest EDS file for the device in question.

It should be available from the mfg and can be installed using the utilities within RSLinx Tools > EDS Hardware Installation Tool.

This is just general advice, I don't know how applicable it is with regard to your revised EWEB card.

Ken Roach
January 23rd, 2007, 07:15 PM
This is an easy fix; you need to download and register the EDS file for the 4.x firmware version of the 1756-EWEB.

Point your browser to http://www.ab.com/networks/eds

Click the "EtherNet/IP" selector and type "1756-EWEB" into the Catalog Number field.

The search will return EDS files for the 1756-EWEB firmware revisions 1.x, 2.x, 3.x, and 4.x. You want the EDS file for version 4.1. Click the "Download File" button and save it somewhere you can find it.

The file name is 0001000C007D0400.eds (http://www.ab.com/networks/eds/cgi-bin/detail.pl?file=EN/0001000C007D0400.eds)

Next, run the EDS Registration Wizard (shut down RSLinx and RSLogix first.).

Start -> Programs -> Rockwell Software -> RSLinx -> Tools -> EDS Hardware Installation Tool.

Follow the prompts to install the EDS file that you just downloaded.

When you restart RSLinx, the 1756-EWEB should be recognized correctly by the RSWho browser.

Ken Roach
January 23rd, 2007, 07:17 PM
I walked a customer through this very thing today; he had RSLinx version 4.2 on his machine and bought a new 1756-ENBT v4 module that wasn't supported until RSLinx 2.50.

But installing RSLinx 2.50 didn't appear to also register the EDS file for the new module. A quick search-download-register and that did the trick.

matger
January 25th, 2007, 10:56 AM
Thanks a lot for the help guys, I appreciate it!