PDA

View Full Version : CLX- Ethernet Produced / Consumed tag problems


Mike6158
December 16th, 2007, 07:42 PM
For some reason I am having trouble setting up a pair of L61 controllers with ethernet cards for producing and consuming tags. I've added ENBT's and set them up per info I found on the Rockwell Knowledgebase system and the ENBT is "faulted". Not the ENBT that I use for the HMI. The ENBT that I have added for the produced / consumed tags. I only need to move 1 real and 1 word. I've set up a UDT in both PLC's. The error that I get is:

Code 16#0109 Connection Request Error. Invalid Connection Size.

What am I missing?

Mike

Operaghost
December 16th, 2007, 08:05 PM
In your I/O configuration take a look at the second/remote ENBT module. Go into the configuration and on the General tab verify that the chassis size setting is correct. I have seen that error when I forgot to set the proper chassis size.

OG

Mike6158
December 16th, 2007, 08:41 PM
:-( well shoot... that's got to be what it is. One rack is a 10 slot rack and one is a 7 slot rack. I overlooked that and both of the racks that I inserted are 17 slot racks. I can't change it without a shutdown and we've had a rough couple of weeks. They'll want to string me up if I have to shut them down. Thankfully the plant is running like **** and it is likely to be down within a few minutes.

Thanks for you help. Sometimes the obvious is transparent :o)

Ken Roach
December 17th, 2007, 12:05 AM
When you create a remote 1756-ENBT in the I/O tree, you can set it up with a "Rack Optimized" connection or a "None" connection. That mismatched I/O size error is very likely on the Rack connection.

Since you're adding a CPU in the remote chassis as a target for the Produced/Consumed Tags, you don't need the Rack Optimized connection. I think you can inhibit it and keep the Produced/Consumed Tag connection.

Either way, the mismatched size Rack Optimized connection is just a nuisance. You can safely ignore it.

Mike6158
December 17th, 2007, 03:45 PM
Thanks Ken. The problem is that along with the error I am not getting any data transfer. Hopefully I'll get an opportunity to correct the problem and download tomorrow.