- Interactive Q & A - Interactive Q & A (
-   LIVE PLC Questions And Answers (
-   -   525 UDFB in CCW (

PLC Pie Guy July 20th, 2017 05:02 AM

525 UDFB in CCW
Hey All.

I got a little problem really kicking my butt here.

Iv been using some Micr820 for this and that. So far so good. A few weeks ago I connected one to a 525 through a small unmanaged switch, I imported the RA_PFx_ENET_STS_CMD UDFB from the AB site. I set it up and with a click I was controlling the drive. No issues. Just a test bench but it was easy.
So I built a machine with two 525 drives in it, a Micro820 and a small 2711P HMI. Its all on its own little network on a 5 port unmanaged switch. I go to commission the machine and all went good. I connected to the drives, flashed firmware, put in my programs and everything tested perfectly. Then it came time to start the motors. I noticed then that the drives were both giving the fault73 error code. I reset them, and once again, the drive fault returned within seconds on both drives.
I'm still connected to them threw CCW and I can go online with it, but my UDFB says its in error. No code, just FBError bit is set as well as the drive fault bit and the comm loss bit. Once the drive is fault cleared, these bits all go back to normalized state.

So... I proceeded to make the parameter for the drive action on comm loss to stop. Sure enough, I can start the drive from the HMI but a second later, it will stop. No fault.

I have tried the following:
-Disable one of the UDFB in the Micro so only one is running at a time.
-unplug one drive from the unmanaged switch.
-delete one drives UDFB from the program.
-ground C2 on the drive.
-swapped out the unmanaged switch for a gigabit switch
-set the Update rate parameter of the UDFB to many vales from 25ms to 1500ms
-set the EnetCtrlTO_sec parameter of the UDFB to many values from 0 sec to 60 seconds.
-set up gateways in the devices
-deleted harmony files (as per Rockwell request)

After all of this having the same result, even if simply trying to run one drive its the same result.

I know my UDFB is working as from my HMI I can clear the fault, start and stop, set the accel and decel, read the output current, see the drive is active or not and even see the fault code. So its talking. But why faulting?

So today... I came to work, grabbed a different Micro820, a different 525, a different 5 port gigabit switch and put it all together. As I expected, comms connected great, I set up the drive and as soon as I gave the start command to the drive, you guessed it......... The F*#*@& fault 73 comes up again.

I spent at least 2 hours yesterday on the phone with Rockwell tech. First I had to deal with the junior who asked me to make sure I had the right firmware, that I had terminal 1 to 11 connected and so on and asked me to delete harmony files. Then I got to talk to a more senior guy who just kept saying he had no real experience with this and also proceed to inform me that really nobody there can provide great support on these UDFB modules.

Is there anybody here that has set this up and figured out this quirk?

Very appreciative of any help.


PLC Pie Guy July 20th, 2017 07:11 AM

So.... After lots of testing and tesing, I still have not figured out why this is happening. However, I have made the drives run solidly by setting parameter 143 to "Send Flt Cfg".

Now the drive can start and stop, its providing all my feedback and responding to my commands. I now have the UDFB update rate set to 50ms. and the UDFB ENet CtrlTO set to 1sec.

I think something is still not happy.

PLC Pie Guy July 24th, 2017 05:16 AM

Hey All.

Well based on the fact that this thread didn't get any responses. I have to assume that either these CCW / Micro PLC set ups aren't that popular and really nobody is using them or my feet stink and nobody wants to talk to me!

Well in case anybody in the future gets stuck on this I will post my findings now that I have success. This was a head scratcher that I found help in resolving by the Rockwell Component Specialist in Laval Quebec. He was more knowledgeable about the product than RA Tech by a mile.

He pointed out to me that when using this UDFB for communications to a 525 I need to use only Local Variables attached to the UDFB. Instead, I had created a user defined tag type that included all my tags for the UDFB. That user defined tag was made global and I used them also in my HMI. WRONG!

I had to create local variables that belonged to the UDFB and push my globals tag values in to them.
Once I did this it worked like a charm! It took him 20 mins to look at my program and explain to me in a quick call what I had done wrong. I would expect RA Tech at thousands a year to do this for me as well. Not the guy who doesn't get anything out of me for his time.

I do like this line up of software and equipment but I do find that the little bit of helpful material that is out the for this stuff is sparse in content and really only explains the basics. Stuff like this is really not printed anywhere and if not for the experience of others I may have abandoned this "conveniently priced software".

ethen December 5th, 2017 07:01 AM

Hi i am new at CCW and Micro800 and also experience the same problem can you perhaps sent images what they did to correct problem?:wish::wish:

PLC Pie Guy December 5th, 2017 07:55 AM

I can screen shot you a few images or... if you PM me your email I can send you a zipped copy of a bare bones CCW program to talk to one drive. It has all the basic control and monitor functions for the 525.
You can download the UDFB and the instructions,,, from the AB site. The UDFB is "RA_PF52x_EIP_STS_CMD" that is probably the first step.
I have used the 820 / 525 combination now with many small machines and works marvelously once you get it going.

***I tried to attach it here but its a little to large.

ethen December 5th, 2017 11:08 PM

Hi Thanks for your quick reply i also use the Micro 820 with CCW my version of CCW is v10. i contact tech support no luck ai but i will appreciate is you can sent your application the only difference is i used two pf525 drives but the concept matter.

My email address are:

it well appreciated.

ethen December 6th, 2017 01:14 AM

I also struggle to find the RA_PF52x_EIP_STS_CMD .

I used in project RA_PF52x_ENET_STS_CMD.


PLC Pie Guy December 6th, 2017 04:27 AM

You should have the file now. That works for me 100% of the time. If you have more questions about setting this up in particular perhaps you should start a new thread.

Have fun!

ethen December 6th, 2017 08:54 AM

Hi Pie Guy

Thanks i will definitely check it out i appreciate it :site:

ethen December 7th, 2017 04:54 AM

Hi PLC Guy

Hope you well. i did export the function block from your program and import it in mine. There is one thing i've notice when i start my process the speed reference change from 1 to 2.

I used a PID control whereby the output of my PID is Scaled 0-100% to 0-5000HZ which give you 0-50Hz for PF525 drives.

As my speed ramp up and down as per my PID the drive frequency stay at 50HZ because it speed reference is no longer 1 its 2 which mean speed reference 2.

Question: How can i prevent it to jump to other speedref. i also tried to put all speed references on 15 which is Ethernet/ip in the PF525.

Thanks i appreciate any help.:wish::wish::wish:

PLC Pie Guy December 7th, 2017 05:52 AM

"As my speed ramp up and down as per my PID the drive frequency stay at 50HZ because it speed reference is no longer 1 its 2 which mean speed reference 2."

I'm not clear on this.

Are you saying that the drive parameter for speed reference is changing from 1 to 2?

Did you set your drive parameters up for Eth I/P control ?

P46 - start source and P47 - Speed reference?

Also make sure that the Min freq. P43 is not set to a high value. Iv seen that happen before. Min = 60HZ so the drive will never ramp down.

ethen December 7th, 2017 10:10 AM

if you look at parameter f705 on the pf525 drive that is 1 and as soon as I press start that parameter is 2, according to the manual if that parameter is 1 its start reference it takes is reference_1 and when 2 takes reference_2. that is what take support telling me.

look at manual 520com-um001_-en-e.pdf on page 153.

*NB you can have a look in my application program P525_Control_A rung 13 and 14 is one of my desperate attempts to see what it does but no luck.

Tech support said that the drive is fine it's something with my micro820. what I can't understand is I can stop start see all drive status the only thing is drive not ramp up and down as my speed reference go up and down it stays at max HZ.

I feel to through this plc away:mddr::mddr:

PLC Pie Guy December 7th, 2017 11:27 AM

1 Attachment(s)
So are you giving a reference that the drive is not following or are you not giving the reference at all. Does the "At reference" bit ever go true?

Your program looks good and the drive parameters, I'm not to familiar with the PID so you might want to ask for other help on that one.

Regarding rung 2 on your pump control routine. I would try simply replacing the tag "Cmd_SpeedRefG" with a new tag that you can just test with. Just try and see if you are changing the input of the function block or not, then is the output of the function block reflecting that value. You do know that on rung 2 of your PF525POU, the speed reference is conditional based on an input that turns on "iPump_A" if that bit never goes true then your speed reference will never change. I'm "assuming, that bit comes on when the motor starts so it "should" be okay...... Not to assume though. See attachment.

If you are giving a changing speed reference, what does parameter 2 show in the drive? If it does reflect the speed reference of the function block than perhaps a drive parameter is the trouble.

Did you do a factory reset on the drive before commissioning?
Perhaps not related but..maybe relevant, did the drive successfully auto tune?

ethen December 8th, 2017 12:42 AM

Hi Mr PLC Guy,

Believe you well. I've manage to get my system up and running.:beerchug:

I notice in your code you sent a scaled value of 0-60Hz to your speed reference and myne is 0-5000Hz as instructed by Tech support, so i've change my scaling to 0-50Hz and it work perfectly.

Thanks again for your support it is well appreciated!!!.

williamdai June 26th, 2018 01:05 PM

can anyone send me the RA_PF52x_ENET_STS_CMD FB? Thanks a lot!

All times are GMT -5. The time now is 01:09 PM.