- Interactive Q & A - Interactive Q & A (
-   LIVE PLC Questions And Answers (
-   -   PLC-5 EtherNet Issues - Access Privileges Denied (

mdemmer October 26th, 2012 08:48 AM

PLC-5 EtherNet Issues - Access Privileges Denied
Hello Group,

I am working on a project with RSLogix5 and an older PLC5/40 Enhanced Processor. I can go online and make edits via RS232 cable on CH0 but my SideCar 3A (1785-ENET) card is not allowing online edits. I also have an HMI that is communicating to this SideCar adapter and there is no issue.

On a side note: I have checked all my passwords and privileges....they are all RW for all 4 classes. We don't actually use this option in our plant so there is no reason to think it is an issue on this tab/setup option. Also, all rungs are set to RW as well as the 3A card is set to RW.

Fault message is as follows:

"Rung could not be inserted into online Processor!
Insert Instruction Failed: Ext Sts = 0x0B
Access Denied - Privilege Violation"

I believe that the card is pooched and I need a replacement but I just want to make sure that I'm not missing these cards are now VERY pricey.

ghriver December 28th, 2012 03:47 PM

i just had a similar problem after using control flash to update the sidecar (series B) from 2.50 to 2.56. after all was complete i attempted to switch back to remote run from rslogix 5 and got access privileges denied. i checked the settings and all seemed good. i called rockwell and by the time i started talking to them i switched it to rem run via software and this time it worked ?????. I was curious if you found a solution on yours?

tomislavj March 8th, 2018 02:17 PM

If you have verified that the PLC program has no security assigned to it, then the reason for that message is that the PLC is almost out of memory.

This happened to me once - cleaned out excess fat from the program, and - viola - edits were possible once again!

controlconcepts March 9th, 2018 02:35 AM

Have had the same thing happen as well. All I did was logged in to a different class even without a password just by clicking OK with a empty password would then allow online editing. Hope this helps.

janner_10 March 9th, 2018 03:44 AM

I would of thought he had solved it after 6 years!

RoTaTech March 9th, 2018 09:04 AM

I would have thought he had solved it or given up after six years.

Geospark March 9th, 2018 09:56 AM

After six years though, and for the sake of future desperate searchers, how about a solution?...

448123 - Online edit of PLC 5 with a 1785-ENET sidecar results in error 0x0B privilege violation
Access Level: TechConnect

This issue is related to the use of the CIP type Ethernet/IP driver in RSLinx Classic when performing online editing via a 1785-ENET sidecar. It only affect sidecars using firmware revisions prior to r3.41. CIP can invoke certain security privilege checks which may be undesirable when interacting with certain devices.

The temporary fix is to instead use the non CIP type Ethernet devices driver to perform online editing.

At firmware revision 3.41 of the 1785-ENET, this anomaly was corrected. Users can now use the CIP type Ethernet/IP driver to perform online editing via the 1785-ENET sidecar without issue. Either driver may now be used.


a062549 March 9th, 2018 10:44 AM

Ah no, sometimes we are a very hard headed lot!! Only to be made better if the Plant Manager is helping you...



Originally Posted by RoTaTech (Post 771324)
I would have thought he had solved it or given up after six years.

All times are GMT -5. The time now is 06:58 AM.