You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
Thread Tools Display Modes
Unread November 6th, 2019, 03:21 PM   #1
Dryhops
Member
United States

Dryhops is offline
 
Join Date: Jan 2018
Location: California
Posts: 66
Problems opening RSLogix5000 v20.00.00

I have a machine that I cannot seem to upload the program from. It kept throwing a fatal error saying that there was an unspecified communications error. The machine is running correctly and hasn't been modified since I started working with it a few years ago.

Fortunately there was a copy of the program on a USB drive. Trying to open it with RSLogix5000 v20.01.00 produces a new error: 'The project file contains an object whose format cannot be converted to it's current version.

I then opened it with RSLogix compare tool which also failed, but at least told me that the version was 20.00 which isn't installed on my computer.

While I have a license which is valid for RSLogix versions <30, it seems rockwell specifically does not allow downloads of version 20.00.00 any more on their website. I understand there were problems between 20.00 and 20.03.

Is there a known solution to this versioning issue? I don't really want to update the firmware, but even if I did I can't open the file to make any adjustments.
  Reply With Quote
Unread November 6th, 2019, 04:15 PM   #2
Aabeck
Member
United States

Aabeck is offline
 
Aabeck's Avatar
 
Join Date: Feb 2013
Location: Detroit
Posts: 1,484
Download the updated versions - 20.05 is the latest, 20.04 also worked.

They are compatible with both 20.01 and 20.03 versions that had some bugs.

It sound like the version used was 20.03 and 20.01 can't open it.

If you are using WIndows 10 after you install it go to the C:\Program Files (x86)\Rockwell Software\RSLogix 5000\ENU\v20\Bin/RS5000.EXE file properties and select Run In Compatibility Mode for Vista, and click Run As Administrator.
__________________
Never underestimate the quality of idiots that will be running your machines
http://aabeck.com
  Reply With Quote
Unread November 6th, 2019, 04:23 PM   #3
Dryhops
Member
United States

Dryhops is offline
 
Join Date: Jan 2018
Location: California
Posts: 66
Thanks for the quick reply. I am downloading 20.05 now and will report back if it works.

I read in another thread that 20.05 resolved some shenanigans with 20.01 and 20.03. Is 20.05 the 'correct' version to use for any v20 .ACDs? In other words, can I uninstall 20.03? Other than this machine, we only have 3 firmware versions used in our facility, so I'd like to uninstall any versions that are redundant.
  Reply With Quote
Unread November 6th, 2019, 04:27 PM   #4
ASF
Lifetime Supporting Member
Australia

ASF is offline
 
Join Date: Jun 2012
Location: Australia
Posts: 2,973
This article does quite a good job of explaining what is the most likely cause of your headache. And in this thread, Ken Roach sums up my feeling on the issue quite neatly in post #7.


TL;DR, download v20.04 or v20.05 (ideally the latter) and your problem will most likely resolve itself. These versions are available for download on the RA website (provided you have a valid serial number/product key and are within the support period).
  Reply With Quote
Unread November 6th, 2019, 04:29 PM   #5
ASF
Lifetime Supporting Member
Australia

ASF is offline
 
Join Date: Jun 2012
Location: Australia
Posts: 2,973
Quote:
Originally Posted by Dryhops View Post
Thanks for the quick reply. I am downloading 20.05 now and will report back if it works.

I read in another thread that 20.05 resolved some shenanigans with 20.01 and 20.03. Is 20.05 the 'correct' version to use for any v20 .ACDs? In other words, can I uninstall 20.03? Other than this machine, we only have 3 firmware versions used in our facility, so I'd like to uninstall any versions that are redundant.

Hit post before I saw your reply...

Yes, 20.05 is the "most correct" version to use. It will overwrite v20.03 when you install it - you can only have one copy of each major revision installed at any given time. i.e. you can have v20.05, 21.03, 23.xx, 24.xx, 26.xx all installed together, but not 20.04 and 20.05. The newer minor revision will overwrite the older.
  Reply With Quote
Unread November 6th, 2019, 05:36 PM   #6
Geospark
Lifetime Supporting Member
Ireland

Geospark is offline
 
Geospark's Avatar
 
Join Date: Feb 2012
Location: Kildare
Posts: 2,778
Quote:
Originally Posted by ASF
...you can only have one copy of each major revision installed at any given time. i.e. you can have v20.05, 21.03, 23.xx, 24.xx, 26.xx all installed together...
You mean v21.00?...not v21.03! May it burn in the pits of Hell and be eternally erased from mind and memory!

I think Rockwell should have released those resiliency versions inside one of these...


I'm sure some felt it was?...

G.
__________________
"A little nonsense now and then is relished by the wisest men".
  Reply With Quote
Unread November 7th, 2019, 01:44 PM   #7
Dryhops
Member
United States

Dryhops is offline
 
Join Date: Jan 2018
Location: California
Posts: 66
Thanks for the help guys - 20.05 seems to have solved my problems. Somehow I missed the fact that minor revisions don't have to match.

Just my luck that all the machines in my facility happen to use the problematic program versions. One day I'll have to move them to a newer version.
  Reply With Quote
Unread November 7th, 2019, 03:41 PM   #8
Aabeck
Member
United States

Aabeck is offline
 
Aabeck's Avatar
 
Join Date: Feb 2013
Location: Detroit
Posts: 1,484
Quote:
Originally Posted by Dryhops View Post
. One day I'll have to move them to a newer version.
You don't have to. The 20.05 will do it when you next open it, and it doesn't change anything in the PLC, so you don't have to download a new version.
__________________
Never underestimate the quality of idiots that will be running your machines
http://aabeck.com
  Reply With Quote
Unread November 8th, 2019, 10:39 AM   #9
Geospark
Lifetime Supporting Member
Ireland

Geospark is offline
 
Geospark's Avatar
 
Join Date: Feb 2012
Location: Kildare
Posts: 2,778
This helps make it all "so" much clearer...

720913 - RSLogix 5000 v.20.04, v 20.05 Compatibility Information
Access Level: Everyone

__________________
"A little nonsense now and then is relished by the wisest men".
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
Achieving order of a pattern in rslogix5000 aec LIVE PLC Questions And Answers 24 January 19th, 2012 07:56 AM
"Usage" view in RSLogix5000 Ver 19 rahulkumardave LIVE PLC Questions And Answers 7 October 7th, 2011 12:32 PM
Problems with Step 7 v5.5 on Windows 7 ? BNA LIVE PLC Questions And Answers 15 August 28th, 2011 08:30 AM
Sinamics and Drive-Cliq problems Combo LIVE PLC Questions And Answers 3 August 20th, 2011 10:38 AM
OP25 / OP27 screen problems. JesperMP LIVE PLC Questions And Answers 5 May 25th, 2005 08:13 AM


All times are GMT -5. The time now is 03:57 PM.


.