You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

Reply
 
Thread Tools Display Modes
Old March 17th, 2023, 03:27 PM   #1
Jcarlow
Member
United States

Jcarlow is offline
 
Join Date: Jul 2021
Location: US
Posts: 3
PowerFlex 40 Won't Start Automatically After Stopping

I have a PowerFlex 40 drive that communicates with a 1756-L61 PLC via an 22-COMM-E card. There's an auxiliary contactor attached to the motor disconnect that interrupts the input to terminal 1 on the drive for the Stop when the disconnect is off. P036 and P038 are set to Comm Port. The VFD is being controlled by an AOI that I'm honestly not quite following along with. Or at least don't quite understand how the drive inputs and outputs interface with the logic. But there's a .Iterlocked_By bit that eventually turns on the Drive_Start bit in the AOI that won't allow the motor to run unless it's high.

On this conveyor that the drive runs, there's a labeler with a verification camera that checks a barcode. If the wrong barcode is read 5 times, there's a fault bit in the logic leading to the interlock output that drops out. I did some testing yesterday and if the interlock output goes high again within 30 seconds, the motor will start up automatically. If the interlock output stays low for more than 30 seconds, I have to turn the disconnect off at the motor, interrupting the stop input to the drive, turn it back on and then the motor runs again. I tested this a dozen times and anything under 30 seconds starts right back up.

The VFD is tagged PF40_5M0. I've noticed that when this happens, PF40_50M0:I.Ready drops out and when I turn the motor disconnect off and back on, it goes high again. I'm just not understanding what the relation is to the Stop input or why there's a 30 second threshold. I'm sure it's something simple I'm missing. I'm much better with logic than I am electrical. This is happening on multiple drives in the same area but from what I can tell, we have a handful of overhead conveyors with the same drive that no one has to go up with a lift to cycle the motor disconnects off and back on to get the motors to run if the line backs up and the conveyors stop. However, the drive parameters look the same.

Hopefully that all makes sense. Any help would be appreciated.

Thanks,
Jason
  Reply With Quote
Old March 17th, 2023, 04:21 PM   #2
Ken Roach
Lifetime Supporting Member + Moderator
United States

Ken Roach is offline
 
Ken Roach's Avatar
 
Join Date: Apr 2002
Location: Seattle, WA
Posts: 16,974
I think this is a case where a verbal description, or even a screenshot, won't do the trick. You'll have to post the AOI and the related motor control code.

It makes sense to have an interlock contact that interrupts Digital Input 1, when that's set for the default function of "STOP". On an A-B drive, a STOP command from any source always overrides the START commands.

I can't say where this 30 second threshold is coming from.

But I will say that a classic programming error with PowerFlex on EtherNet/IP or ControlNet is that if the Start bit goes from false to true when there is still an active STOP command, the drive will "ignore" the Start command.

The most common error is to write your STOP bit (which =1 to Stop over the network) so that it only goes =0 when the START bit goes =1. If the cyclic I/O update timeout happens to occur in between those logic rungs or instructions, then both START and STOP are =1 at the same time, and STOP wins.

If your logic is set up that it might send a START command over the network while the STOP command is still asserted by a physical Digital Input, that would explain why the Start appears to be "ignored" or will not start the motor like you expect it to.
  Reply With Quote
Old March 17th, 2023, 04:37 PM   #3
Ken Roach
Lifetime Supporting Member + Moderator
United States

Ken Roach is offline
 
Ken Roach's Avatar
 
Join Date: Apr 2002
Location: Seattle, WA
Posts: 16,974
Also: welcome to the PLCTalk forum community !

We like long-form posts, links to resources and documents, and screenshots.

Not like those buncha jabronis over at the reddit/r/PLC site.
  Reply With Quote
Old March 17th, 2023, 05:03 PM   #4
Jcarlow
Member
United States

Jcarlow is offline
 
Join Date: Jul 2021
Location: US
Posts: 3
Ken,

I appreciate you getting back to me and the warm welcome. I've been looking through these forums since I got into this field 3 years ago and your answers to others questions have helped me more times than I can count. So, thank you.

I've left work for the weekend but I've asked for a coworker to send me a picture of the AOI logic and the rung with the Interlock logic on it. If I hear back, I'll post what he sends me. Otherwise I'll get that on here as soon as I get back to work on Monday.

Thanks,
Jason
  Reply With Quote
Old March 20th, 2023, 07:54 AM   #5
Jcarlow
Member
United States

Jcarlow is offline
 
Join Date: Jul 2021
Location: US
Posts: 3
Here's a copy of the AOI and a picture of the Interlock logic.

_Prg_BOOL[1].2 is just a start command for a group of conveyors from an HMI.

Motor_50M0.Ready is the bit that drops out after 30 seconds and won't go high again until the motor disconnect is cycled.

Labelers_FAULT_A is a fault for a barcode inspection camera. If the camera records 5 bad reads in a row, this fault comes on and is reset with a local push button.

SS_50M4 is an auto / manual selector switch for a downstream conveyor.

Please let me know if you need any other information.

-Jason
Attached Files
File Type: zip VFDAOI.zip (197.8 KB, 4 views)
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
PowerFlex 525 Start Issue ncs LIVE PLC Questions And Answers 2 February 20th, 2023 03:27 AM
Help with a Powerflex 40 bcard519 LIVE PLC Questions And Answers 5 July 31st, 2015 09:07 AM
Read Ethernet/IP Parameters from PowerFlex 40 Drive use Anybus-X-Gateway Teaan van Staden LIVE PLC Questions And Answers 1 April 23rd, 2015 09:57 AM
Interfacing PanelView 300, Powerflex 40 and SLC503 Processor dabanani LIVE PLC Questions And Answers 11 October 16th, 2010 10:12 PM
Lessons Learned - Powerflex 40 Drive Won't Start recondaddy LIVE PLC Questions And Answers 1 February 24th, 2008 12:27 PM


All times are GMT -4. The time now is 05:58 AM.


.