You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
 
Thread Tools Display Modes
Old February 13th, 2020, 05:53 PM   #1
bamconner
Member
United States

bamconner is offline
 
Join Date: Nov 2019
Location: United States
Posts: 2
Logix5562 with DHRIO to 1771-ASB E Faults

Hey everyone,

Long time user of the site but this is my first time posting.

I have a 1756-A4 rack with a Logix5562 in slot 0, 1756 ENBT/A in slot 1, and a 1756-DHRIO/C in slot 3. I am trying to drive PLC5 IO via a 1771-ASB E card and am getting faults. Here is the pre-information (referencing Publication 1771-UM001A-US-P - February 2000:

1771 A2B 8-slot chassis switch settings:
1:Off (Outputs of this I/O chassis are deenergized when a fault is detected)
2:On (Processor can restart I/O chassis)
3:Off (Always Off)
4:Off (Always Off)
5:Off
6:On (1/2 Slot Addressing)
7:Off (Always Off)
8:Off (Always Off)

1771-ASB E Switch Settings
1:On
2:On
3:On
4:On
5:On
6:Off (IO Rack # 01)
7:Off
8:Off (First IO Group Number = 0)

1:On
2:Off (Baud 57.6k (this is a test stand setup))
3:Off (Always off)
4:Off (Scan - Off for all slots)
5:Off (Link response - Off for unrestricted)
6:Off (Always off)

I set up a 1771-ASB in my configuration tree and have matched the above settings in its configuration.

Before turning on the A2B 8-slot chassis I get the fault (Code 16#0312) Connection Request Error: Invalid Link Address . CHA is blinking green, CHB is blinking red

When everything is powered on I get no lights on the 1771 ASB and get the fault (Code 16#0109) Connection Request Error: Invalid Connection Size. CHA is blinking green, CHB is solid green.

The bugger about all of this is I had it working about 6 months ago when a project was put on hold. I'm sure its something small that I'm missing but any ideas or comments will be greatly appreciated.

Cheers!
  Reply With Quote
Old February 13th, 2020, 08:41 PM   #2
Ken Roach
Lifetime Supporting Member + Moderator
United States

Ken Roach is offline
 
Ken Roach's Avatar
 
Join Date: Apr 2002
Location: Seattle, WA
Posts: 15,107
Welcome (officially) to the PLCTalk.net forum community !

To confirm: your DHRIO module is physically in Slot 3, and your configuration is for Slot 3 as well.

Which channel is your RIO connected to ? What is connected to the other channel (and how is it configured) ?

Is there a message on the dot matrix display of the 1756-DHRIO ?

The 1771-ASB adapter object for 1/2 slot addressing should allow an 8-slot chassis to appear as two logical "Racks", 01 and 02. Unless you are using 32-bit modules, 1-Slot addressing is more conventional.

That might explain the "invalid connection size" if you have only one 1-Rack object in the scanlist.
  Reply With Quote
Old February 14th, 2020, 09:14 AM   #3
bamconner
Member
United States

bamconner is offline
 
Join Date: Nov 2019
Location: United States
Posts: 2
Ken, thanks for the reply. That was the issue. I was getting 1/2 slot and 1/2 rack configurations confused - the way I had it working before was with 2 slot addressing on the 1771 chassis and 1/2 rack selected in RS5000. I got it working with both 1 slot addressing and full rack as well as 2 slot and 1/2 rack. The difference between the two was which tags my discrete IO effected.
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
1756 DHRIO communication timeout Kthomas816 LIVE PLC Questions And Answers 1 July 8th, 2019 11:52 AM
1771 ASB Failures ersanjit LIVE PLC Questions And Answers 6 July 3rd, 2019 07:49 AM
Configuring 1771 RIO Chassis Oceansoul LIVE PLC Questions And Answers 3 November 4th, 2015 03:40 AM
ControlLogix and 1771 I/O usmcgrover LIVE PLC Questions And Answers 5 December 23rd, 2007 07:12 AM
Configuring an ASB Module for a 1771 Chassis specialkc LIVE PLC Questions And Answers 1 September 22nd, 2005 04:22 AM


All times are GMT -5. The time now is 09:31 AM.


.