You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
 
Thread Tools Display Modes
Old November 19th, 2018, 02:01 PM   #1
Cydog
Member
United States

Cydog is offline
 
Join Date: Feb 2018
Location: Maryland
Posts: 89
PowerFlex 525 - Speed Reference by Ethernet is set to 0 but still runs at 60 HZ

Good Afternoon ,

I'm sorry , but here is another one. I have the PowerFlex 525 speed reference set to Ethernet / IP and it is running at 60 HZ . The PLC is telling
it to run 0 HZ , but it still wants to run at 60 HZ. The b002 ( Commanded Freq ) is saying 60.0 HZ . I have all the speed references set to 15 ( EtherNet / IP ) . I change it to 1 ( Drive Pot ) and it goes down to 0 and then I can control the speed with the pot. Ethernet is telling it to run that speed .

Have you guys seen this before ? It blows my mind .

Thanks for your help again.
  Reply With Quote
Old November 19th, 2018, 02:18 PM   #2
Cydog
Member
United States

Cydog is offline
 
Join Date: Feb 2018
Location: Maryland
Posts: 89
* Update * - I took notice that my Frequency Command was -1 . I put a AFI before my MUL instruction , and made it 0 and the speed went down to 0. I'm using REAL numbers to set my speed desire than using a MUL by 100 to get my command frequency .
  Reply With Quote
Old November 19th, 2018, 03:00 PM   #3
Cydog
Member
United States

Cydog is offline
 
Join Date: Feb 2018
Location: Maryland
Posts: 89
Nevermind this post. It was my code . I'm sorry.
  Reply With Quote
Old November 19th, 2018, 06:24 PM   #4
Geospark
Lifetime Supporting Member
Ireland

Geospark is offline
 
Geospark's Avatar
 
Join Date: Feb 2012
Location: Kildare
Posts: 2,484
Quote:
Originally Posted by Cydog
...I'm using REAL numbers to set my speed desire than using a MUL by 100 to get my command frequency...
Just to be clear (not just for you but also for other readers)...

For the PowerFlex 525 the Reference and Feedback are 16-bit integer values (INT) which represent drive speed in 0.01 Hz.
The desired Hz needs to be multiplied by the scaling factor of 100. For example, if you need 32.5 Hz you would send over 32.5 x 100 = 3250 as an INT to the drive.

If the 32.5 Hz speed reference is a REAL, say entered by a User on a HMI, then while applying scaling (mul x 100) you must also convert the REAL result to an INT before sending it to the drive's output image.

I'm not saying that this has anything to do with what you had "wrong" here. It's just how the above reads. It might suggest to some that using REALs all the way is a viable option.

Regards,
George
__________________
"A little nonsense now and then is relished by the wisest men".
  Reply With Quote
Old November 22nd, 2018, 02:52 PM   #5
BruceJW
Member
South Africa

BruceJW is offline
 
Join Date: Jan 2006
Location: Randburg
Posts: 55
Quote:
Originally Posted by Cydog View Post
Nevermind this post. It was my code . I'm sorry.
it happens, don't feel bad.
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
Powerflex 70 upgrade Ethernet or RIO DAnderson LIVE PLC Questions And Answers 10 August 28th, 2012 07:28 AM
ServoStar 600 positioning through Profibus and a S7 Program. pietervdb LIVE PLC Questions And Answers 11 August 9th, 2007 07:47 AM
OT:Frequency RheinhardtP LIVE PLC Questions And Answers 1 August 15th, 2006 10:28 AM
Dancer Systems scottmurphy LIVE PLC Questions And Answers 66 May 10th, 2006 11:47 AM
GE Fanuc VersaMax PID control problem Shawn Cassidy LIVE PLC Questions And Answers 6 May 16th, 2004 09:10 AM


All times are GMT -5. The time now is 10:57 PM.


.