You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

Reply
 
Thread Tools Display Modes
Old September 15th, 2021, 08:55 AM   #1
mhertwig
Member
Canada

mhertwig is offline
 
Join Date: Sep 2021
Location: London
Posts: 5
Fatal Error - Panelview Plus 1000

Hey there. I have a PV Plus 1000 FW: 5.10.16.09

I cannot change the communication setup to direct my device shortcut to a different PLC.

This happens with multiple HMIs, so I suspect this is a software issue.

Error:

"Application RSLinxNG.EXE has performed an illegal operation and will be shut down. If the problem persists, contact the program vendor.
Program: RSLinxNG>EXE
Exception: 0xc0000005
Address: 018fe87b
"

When I download my .mer without replacing comm path and leaving the original setup its fine. This only happens if I change the comm path to a new PLC.

Thoughts?
  Reply With Quote
Old September 15th, 2021, 08:56 AM   #2
mhertwig
Member
Canada

mhertwig is offline
 
Join Date: Sep 2021
Location: London
Posts: 5
After this error I cannot communicate with the HMI until I load in the old .mer file and replace communications again.
  Reply With Quote
Old September 15th, 2021, 10:04 AM   #3
dmroeder
Lifetime Supporting Member
United States

dmroeder is offline
 
dmroeder's Avatar
 
Join Date: Apr 2006
Location: Vancouver, WA
Posts: 2,914
Using the "copy from design to runtime" button appears to trigger this bug. If you delete the communication path and create it manually, I wonder if it will work (don't use the copy button).

According to KB BF25737, you must be on 5.10.16 (which you are) and you must apply the latest rollup patch to FactoryTalk View Studio. Then the copy design to runtime should work properly.
__________________
If you can, support my lifelong friends childhood cancer awareness month band-aid drive (select deliver to Eli) Here is an article.
  Reply With Quote
Old September 15th, 2021, 11:13 AM   #4
mhertwig
Member
Canada

mhertwig is offline
 
Join Date: Sep 2021
Location: London
Posts: 5
Doing that I get this:

"
*** Start FactoryTalk Linx Conversion Messages ***

WARNING: Unconfigured shortcut detected. Shortcut name = "PLC". Description: The system has detected that the noted shortcut has not been associated with a device on the Runtime (Target) tab. If the application makes use of this shortcut, then runtime errors will be detected and logged when the application attempts to use that shortcut.

*** End FactoryTalk Linx Conversion Messages ***

Validation completed with warnings. The runtime application has been created.
CAUTION: Running this application might produce errors at runtime.
"

Simulating on my desktop works fine. The PV, however, does not.

I'm running 11.00.00 (CPR 9 SR 11)...
  Reply With Quote
Old September 15th, 2021, 11:21 AM   #5
mhertwig
Member
Canada

mhertwig is offline
 
Join Date: Sep 2021
Location: London
Posts: 5
Update... Do the following:

1. delete existing FT Linx
2. create new FT Linx server
3. select "Copy the configuration that is currently running on this workstation"
4. On runtime only add your device shortcut & point to the PLC

This eliminates the need to hit "copy from design to runtime" button
  Reply With Quote
Old September 15th, 2021, 11:24 AM   #6
mhertwig
Member
Canada

mhertwig is offline
 
Join Date: Sep 2021
Location: London
Posts: 5
Quote:
Originally Posted by dmroeder View Post
Using the "copy from design to runtime" button appears to trigger this bug. If you delete the communication path and create it manually, I wonder if it will work (don't use the copy button).

According to KB BF25737, you must be on 5.10.16 (which you are) and you must apply the latest rollup patch to FactoryTalk View Studio. Then the copy design to runtime should work properly.
Thank you for your help!
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
Panelview plus 1000: fatal application error yassine.Tunisia LIVE PLC Questions And Answers 5 September 11th, 2020 12:34 PM
pvp+ 1000 compact ttis LIVE PLC Questions And Answers 1 August 11th, 2020 02:31 PM
fatal error when add ethernet device mike3475 LIVE PLC Questions And Answers 11 November 25th, 2019 08:05 PM
AB Panel View 6 Plus 1000 Saurabh Trivedi LIVE PLC Questions And Answers 1 November 6th, 2014 06:17 AM
S7:Local Memory/Pointer question STL??? LIVE PLC Questions And Answers 2 April 12th, 2006 03:48 AM


All times are GMT -4. The time now is 08:33 AM.


.