You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

Reply
 
Thread Tools Display Modes
Old August 23rd, 2015, 02:28 AM   #1
Skiroy
Member
United States

Skiroy is offline
 
Join Date: Mar 2012
Location: Panama City,fl
Posts: 199
RS LOGIX 5000 emulate

Do you still have to purchase RS LINX and RS Logix 5000 in addition to emulate or does emulate 5000 have all the program platform included?
  Reply With Quote
Old August 23rd, 2015, 01:15 PM   #2
Geospark
Lifetime Supporting Member
Ireland

Geospark is offline
 
Geospark's Avatar
 
Join Date: Feb 2012
Location: Kildare
Posts: 3,011
I'm afraid not...

RSLogix 5000/Logix Designer do not come with a purchase of RSLogix Emulate 5000.

It's actually the other way around...

RSLogix Emulate 5000 is more of an add-on or complimentary software product to RSLogix 5000/Logix Designer. It comes included when you purchase RSLogix 5000/Studio 5000 Professional Edition, or is available separately with other Editions. You must have purchased RSLogix 5000 or Studio 5000 already to use RSLogix Emulate 5000.

If you do not have the Professional Edition then you will not automatically have RSLogix Emulate 5000. Also, the Lite and Mini Editions of RSLogix 5000 /Logix Designer do not support RSLogix Emulate 5000.

Additionally, which Operating System you install it on can dictate which previous project versions you can work with.

As I'm sure you are aware, it emulates the processor and chassis for testing and debugging. It is an additional tool to the programming software, but not a free tool.

RSLinx Classic Lite comes included with just about every major software product that Rockwell sells. If it doesn't, you can download it individually for free.

Regards,
George
__________________
"A little nonsense now and then is relished by the wisest men".
  Reply With Quote
Old August 23rd, 2015, 04:54 PM   #3
Skiroy
Member
United States

Skiroy is offline
 
Join Date: Mar 2012
Location: Panama City,fl
Posts: 199
So the free version of RS Linx Lite works with RS Logix 5000 without a license for RS Linx?
  Reply With Quote
Old August 23rd, 2015, 05:26 PM   #4
jkerekes
Member
United States

jkerekes is offline
 
jkerekes's Avatar
 
Join Date: Aug 2007
Location: NJ
Posts: 2,338
Yes.
__________________
John
  Reply With Quote
Old August 24th, 2015, 12:36 PM   #5
Skiroy
Member
United States

Skiroy is offline
 
Join Date: Mar 2012
Location: Panama City,fl
Posts: 199
Will Emulate v17 work with RSLogix 5000 v20?
  Reply With Quote
Old August 24th, 2015, 12:47 PM   #6
jkerekes
Member
United States

jkerekes is offline
 
jkerekes's Avatar
 
Join Date: Aug 2007
Location: NJ
Posts: 2,338
No. Just like a physical controller, the versions much match. Now versions of Emulate will support a few firmware revs BEHIND the current version. But a ver. 17 Emulate won't support version 20. I have version 24 of Emulate which can create a controller back to version 20. I'm not sure how far back version 20 of Emulate goes.
__________________
John
  Reply With Quote
Old August 24th, 2015, 01:24 PM   #7
Skiroy
Member
United States

Skiroy is offline
 
Join Date: Mar 2012
Location: Panama City,fl
Posts: 199
I are there any issues with compatibility for Windows XP SP2 as I have read SP3 is used but I cant find it?

How does SoftLogix 5800 v20 differ from emulate?
  Reply With Quote
Old August 24th, 2015, 01:44 PM   #8
jkerekes
Member
United States

jkerekes is offline
 
jkerekes's Avatar
 
Join Date: Aug 2007
Location: NJ
Posts: 2,338
There's the compatibility section on the Rockwell Site that will tell you all the compatibility issues of all their software.

SoftLogix is a software based PLC. Unlike Emulate, SoftLogix can control real I/O. The two are incompatible with each other. That is, they can't both be installed on the same computer.
__________________
John
  Reply With Quote
Old August 24th, 2015, 01:56 PM   #9
Geospark
Lifetime Supporting Member
Ireland

Geospark is offline
 
Geospark's Avatar
 
Join Date: Feb 2012
Location: Kildare
Posts: 3,011
Quote:
Originally Posted by jkerekes
...I'm not sure how far back version 20 of Emulate goes.
John,

Remember I mentioned...

"...Additionally, which Operating System you install it on can dictate which previous project versions you can work with..."

If installed on Windows XP then v20 of RSLogix Emulate 5000 can support v12 - v20 inclusive.

If installed on Windows 7 32-bit it will just support v17 - v20 inclusive.

If installed on Windows 7 64-bit it will only support v20.

Such fun!

Regards,
George
__________________
"A little nonsense now and then is relished by the wisest men".
  Reply With Quote
Old August 24th, 2015, 02:20 PM   #10
Skiroy
Member
United States

Skiroy is offline
 
Join Date: Mar 2012
Location: Panama City,fl
Posts: 199
Quote:
Originally Posted by jkerekes View Post
There's the compatibility section on the Rockwell Site that will tell you all the compatibility issues of all their software.

SoftLogix is a software based PLC. Unlike Emulate, SoftLogix can control real I/O. The two are incompatible with each other. That is, they can't both be installed on the same computer.
But softlogix 5800 will enable me to run RS LOGIX 5000 ?
  Reply With Quote
Old August 24th, 2015, 05:15 PM   #11
jkerekes
Member
United States

jkerekes is offline
 
jkerekes's Avatar
 
Join Date: Aug 2007
Location: NJ
Posts: 2,338
Quote:
Originally Posted by Skiroy View Post
But softlogix 5800 will enable me to run RS LOGIX 5000 ?
Yes. It's a full blown PLC running on a PC. It's designed to control things just like a hardware PLC. The firmware revisions still need to match. I think the cost of SoftLogix is higher though and takes a significant toll on your PC resources, as I remember.
__________________
John
  Reply With Quote
Old August 24th, 2015, 05:47 PM   #12
Skiroy
Member
United States

Skiroy is offline
 
Join Date: Mar 2012
Location: Panama City,fl
Posts: 199
So whats the difference between RS Linx Lite and classic? Can I still use lite for SoftLogix,RSLOGIX 5000,Factory Talk View and RS NETWORX?

Do you have to have a serial or activation for the free version of RS LINX?

Last edited by Skiroy; August 24th, 2015 at 05:49 PM.
  Reply With Quote
Old August 24th, 2015, 06:28 PM   #13
Operaghost
Member
United States

Operaghost is offline
 
Operaghost's Avatar
 
Join Date: Apr 2002
Location: Dallas, TX USA
Posts: 3,115
There is nothing actually named "RSLinx Lite".

RSLinx was renamed several years ago so that it is now called "RSLinx Classic". There are different versions of RSLinx Classic. Lite, Single Node, Professional, Gateway are all different versions of RSLinx Classic.

Lite is the free/bundled version and all that most people actually need. The other versions add varying levels of OPC capabilities. If you don't need OPC then RSLinx Classic Lite is all you require. SoftLogix and Emulate do not require OPC.

OG
  Reply With Quote
Old August 24th, 2015, 09:05 PM   #14
Skiroy
Member
United States

Skiroy is offline
 
Join Date: Mar 2012
Location: Panama City,fl
Posts: 199
Quote:
Originally Posted by Operaghost View Post
There is nothing actually named "RSLinx Lite".

RSLinx was renamed several years ago so that it is now called "RSLinx Classic". There are different versions of RSLinx Classic. Lite, Single Node, Professional, Gateway are all different versions of RSLinx Classic.

Lite is the free/bundled version and all that most people actually need. The other versions add varying levels of OPC capabilities. If you don't need OPC then RSLinx Classic Lite is all you require. SoftLogix and Emulate do not require OPC.

OG
Is there compatibility issues with using a newer version of RS Linx lite with older emulate and RS Logix 5000 versions?
  Reply With Quote
Old August 25th, 2015, 05:31 AM   #15
Geospark
Lifetime Supporting Member
Ireland

Geospark is offline
 
Geospark's Avatar
 
Join Date: Feb 2012
Location: Kildare
Posts: 3,011
Quote:
Originally Posted by Skiroy
Is there compatibility issues with using a newer version of RS Linx lite with older emulate and RS Logix 5000 versions?
Yes, there may be, but we won't dwell on that. Let's focus more on what you do need...

You seem a little fixated on "RS Linx lite" and what will or will not work with it.

Firstly, and as similarly mentioned, it is called RSLinx Classic Lite. Also, as mentioned, it is available to download for free. So no matter which version of RSLinx Classic Lite you would need to use with which ever version of RSLogix 5000 you are using, you can download any version of RSLinx Classic Lite to suit your needs. So RSLinx Classic Lite should not be your real concern here.

Also, as mentioned, you need to lock step the versions of RSLogix Emulate 5000 and RSLogix 5000 that you want to use together. Lock step just means to match them at compatible versions. This does not always mean they are at the same exact version.

For instance, if you look at the info I posted last, RSLogix Emulate v20 will work, under Windows XP, with all versions of RSLogix 5000 from v12 - v20 inclusive.

However...

Quote:
Originally Posted by Skiroy
Will Emulate v17 work with RSLogix 5000 v20?
...when a version of RSLogix Emulate 5000 is older than a version of RSLogix 5000, then this is not lock stepped and will not work. RSLogix Emulate 5000 v17 cannot emulate a firmware revision 20 controller. It is newer.

From the above you have mentioned RSLogix 5000 v20....

To Emulate with an RSLogix 5000 v20 project, the emulated controller must be at firmware revision 20. To do this you will require RSLogix Emulate 5000 v20 minimum.

So, the RSLogix Emulate 5000 v17 you have mentioned...

RSLogix Emulate 5000 v17 is not lock stepped with RSLogix 5000 v20 and so you cannot use them together. You will need to upgrade to RSLogix Emulate 5000 v20. So with that established, if you own the copy of RSLogix Emulate 5000 v17, and you have a TechConnect Support Contract, then you should be able to download RSLogix Emulate 5000 v20 from their Software Downloads webpage.

When you download RSLogix Emulate 5000, RSLinx Classic Lite is also added automatically to the download list. However, you must download the correct version of RSLinx Classic Lite that is lock stepped with RSLogix 5000 v20. This is v2.57 minimum, but I would recommend downloading v2.59. This is the highest version of RSLinx Classic Lite supported for use with RSLogix 5000 v20.

If you do not have a support contract, then you cannot download RSLogix Emulate 5000. You would have to purchase RSLogix Emulate v20 as an upgrade.

I hope that is clear enough.

Regards,
George
__________________
"A little nonsense now and then is relished by the wisest men".
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
RS Logix Emulate 5000 fabian24 LIVE PLC Questions And Answers 4 February 24th, 2011 11:42 PM
RS Logix 5000 installation on windows 7 hasan_ali LIVE PLC Questions And Answers 2 July 9th, 2010 09:53 AM
Rs Logix 5000 training Maintenance Man LIVE PLC Questions And Answers 1 January 15th, 2009 01:13 AM
Create Function Block RS Logix 5000 mrsoliveira LIVE PLC Questions And Answers 1 September 10th, 2008 11:35 AM
Copy Rs Logix 500 In Another Computer sanjay_snj LIVE PLC Questions And Answers 9 April 16th, 2006 05:41 AM


All times are GMT -4. The time now is 02:18 PM.


.