You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
 
Thread Tools Display Modes
Old January 12th, 2019, 04:56 PM   #1
SPAZ
Member
United States

SPAZ is offline
 
Join Date: Jan 2019
Location: Wisconsin
Posts: 4
RSLinx Classic Activation Problem

Hello all.
Just ran into a problem recently, and I’m guessing it might be somewhat common. I bought a license on 1/4/19 for RSLInx Classic – Single Node, installed it on Windows 10 laptop, and it ran fine for exactly one week and then it automatically dropped back to the “Lite” version. During the week, it was fine during as I have been using the OPC server.

On closer inspection now, I’m guessing the activation I did after install never took (and no error was displayed,) so it was just running the 7 day grace period. Uninstalled and re-installed 4 times and just gave up. Made sure firewalls and virus scanner was down. The feedback from the installation process is horrible, and there is never any real indication as to what is going wrong. However, I did pick this off the top of an RA log text file just after one failed activation attempt right after re-installation (note divide by zero) –

System.Reflection.TargetInvocationException: An exception occurred during the operation, making the result invalid. Check InnerException for exception details. ---> System.DivideByZeroException: Attempted to divide by zero.

I tried to go through activation again in FactoryTalk Activation Manager, and the application just closes (crashes really) just after I hit "validate." No feedback on whether license is invalid or anything else. Went online to Rockwell activation site and to try the same thing, but it asks for “data file” after serial number and key, and I have no idea what that might be.

So, I have a ticket in for just activation tech support from RA, and sent an email to local distributor. Unfortunately, I have a field service call set up on Monday morning as it was fine all week so I'm hosed unless I can sort it out this weekend.



Anyone run into this before and figure out how to fix it? I have searched other threads here on activation, and this one seems a bit different. I only have RSLinx 4.10.00. Just downloaded latest version and tried that, same problem.


Thanks very much.
  Reply With Quote
Old January 12th, 2019, 07:10 PM   #2
ArtWalls
Member
United States

ArtWalls is offline
 
Join Date: Apr 2016
Location: Miami, Arizona
Posts: 53
You might try installing the latest version of ActivationManager, or reinstalling it. Remove CodeMeter as well, it gets installed with AM. Once that goes, if RSLinx still isn’t working, try rehosting it and reactivating it.
  Reply With Quote
Old January 12th, 2019, 08:06 PM   #3
SPAZ
Member
United States

SPAZ is offline
 
Join Date: Jan 2019
Location: Wisconsin
Posts: 4
Thanks ArtWalls. I did try that, as I removed everything and re-installed it all every time along with RSLinx. I even went so far as to remove any trace of all of the RA tools from the Windows registry so every new install would go in clean. Did not help. Same problem came back each time.



I found that using "uninstall" tools really does not clean up everything, and you have to go in and pick through the directories for a lot of leftovers.
  Reply With Quote
Old January 12th, 2019, 11:04 PM   #4
SPAZ
Member
United States

SPAZ is offline
 
Join Date: Jan 2019
Location: Wisconsin
Posts: 4
Figured it out, after only 12 hours of screwing around….

FactoryTalk Activation Manager application doesn’t work at all for initial activation, crashes. Not sure why, but finally gave up. Activation method right after install also fails every time.


So, I used the RA website online activation method, which is more involved. Since this license is node locked, I got the 6- digit binding ID (serial hard drive#) from Windows “cmd” command, and entered that with serial number, key, and software version. It was critical to pick the software version that the license key came with, as the drive serial number entry field doesn’t show up if you pick a later install version (even if you already have that latest version installed.) Make sure to activate on version you bought, not the current version that’s loaded on PC. Activation seems linked to old version. After that, license file downloads to “Download” directory, and you have to find it and manually copy it to the actual license area of RA – which is bizarre. Wow.

So, it all works, but I am absolutely stunned at how much struggling I have had to do with just this one program activation. Horrible. None of this is intuitive at all. I can only assume that the node-locked activation process is struggling to get the hard disk serial number on my PC (even with no active firewall or virus scanner) - but there is no feedback on that, and things just crash and vanish.



My hope is that maybe this post will save someone 12 hours and some hair.
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
RSLinx Classic Driver Transferring dcooper33 LIVE PLC Questions And Answers 14 June 14th, 2013 06:11 PM
Problem with RSLinx Factory Talk Activation Coulombboy LIVE PLC Questions And Answers 2 September 22nd, 2012 03:29 AM
RSLinx Classic problem paulrae LIVE PLC Questions And Answers 9 March 10th, 2012 06:50 PM
PV 600 Plus - Cockpit Trouble glaw LIVE PLC Questions And Answers 24 June 30th, 2006 10:53 AM
RSLinx communication problem ashley LIVE PLC Questions And Answers 9 July 30th, 2002 06:11 AM


All times are GMT -5. The time now is 09:35 PM.


.