You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
 
Thread Tools Display Modes
Old March 14th, 2013, 12:26 PM   #1
Stephen D
Member
United Kingdom

Stephen D is offline
 
Join Date: Oct 2012
Location: Wales
Posts: 9
Hi! FT View Studio unable to upgrade firmware

Please could someone put me in the right direction.

I'm using first FT View Studio for the first time, so I have modified a sample template just to set up the ethernet comms link between the pc and PV 1500 terminal vers 6.0 and Studio vers 5.10.

As I understand these two versions need to be matched before I can download into the terminal.

I'm unable to upgrade the firmware in the PV as it is saying that it is unable to connect to remote terminal.

I can view the terminal and plc in the Linx Enterprise browser, and can also 'ping' the terminal.

I have also have made a device shortcut and then copied into runtime from local and created a runtime application and tried to transfer that into the terminal but it's coming back with destination selected is not a valid device. That is why I thought there is a mismatch in versions.

Please any ideas to what I do next, I have been on this for a couple of days.

Many Thanks

Steve
  Reply With Quote
Old March 14th, 2013, 12:58 PM   #2
dmargineau
Lifetime Supporting Member
United States

dmargineau is offline
 
dmargineau's Avatar
 
Join Date: Dec 2011
Location: Midwest
Posts: 2,385
Welcome to the Forum Steve.
Let's decide first what you are trying to accomplish.
There are two mentioned "subjects".
One is the editing of a FTVS application and the the consequent runtime file transfer to the terminal.
The other one is the HMI terminal firmware update.
I believe the latter should not be attempted over the network and it is usually performed using a FUP (Firmware Upgrade) Kit deployed via a CompactFlash or USB removeble media directly on the terminal.
The issue you are encountering is not being able to send the Runtime application (.mer) to the terminal.
If you'd have a terminal-Runtime firmware revision mismatch the Transfer Utility will prompt you accordingly.
"Not a Valid Device" means that the Runtime you are trying to download is "aimed" to a device which is not what the FTV Transfer Utility "thinks" it should be.
Could you post a screenshoot of the "download" error you encounter?
  Reply With Quote
Old March 14th, 2013, 01:34 PM   #3
Ken Roach
Lifetime Supporting Member + Moderator
United States

Ken Roach is offline
 
Ken Roach's Avatar
 
Join Date: Apr 2002
Location: Seattle, WA
Posts: 14,292
Both issues you are encountering come from the fact that RA made a major hardware, operating system, and firmware change starting with FactoryTalk View Studio and PanelView Plus 6.0.

The part numbers for the logic modules and assembled terminals are even different. You'll find a lot of the literature and Knowledgebase documents refer to "PV+ 6".

PV+ 6.x terminals cannot be loaded with version 5.x firmware, and PV+ terminals from versions 3.x, 4.x, and 5.x cannot be loaded with version 6.x firmware.

The good news: PanelView Plus terminals can run older-version Runtime files, as far back as Version 3.0.

You can create a Runtime file (*.MER) with FactoryTalk View Studio 5.10, and load it onto the PanelView Plus terminal. It will run.

However, the older RSLinx Enterprise and FactoryTalk View Studio (and Transfer Utility) will not recognize the newer PV+6 firmware, so you won't be able to use the network transfer utility without performing a specific patch / upgrade. I don't have the details on how that patch/upgrade is done.

My recommendation is that you use the removable SD card or a USB removable drive to transfer the Runtime file from your PC to the PanelView Plus terminal.

Quick hints: you need to know two specific directory paths.

On the FactoryTalk View Studio computer, the default destination folder for Runtime files is:

C:\Documents and Settings\All Users\Documents\RSView Enterprise\ME\Runtime

On the removable SD card or USB drive, the following directory must be used:

[Root]\Rockwell Software\RsViewME\Runtime

Note the space in "Rockwell Software" and no space in "RsViewME". The PV+ requires this exact path or it won't see the *.MER files in the File Management screens in the Configuration menus.

The removable SD card is considered "External Storage 1". A USB drive is considered "External Storage 2". Both SD cards and USB drives must use FAT file format, when generally means they must be under 2 GB.
  Reply With Quote
Old March 18th, 2013, 09:30 AM   #4
Stephen D
Member
United Kingdom

Stephen D is offline
 
Join Date: Oct 2012
Location: Wales
Posts: 9
Thankyou both for your help, looks like I need to speak Rockwell (again!!) for an upgrade patch.
  Reply With Quote
Old March 18th, 2013, 10:48 AM   #5
Stephen D
Member
United Kingdom

Stephen D is offline
 
Join Date: Oct 2012
Location: Wales
Posts: 9
dmargineau

I have attached the screen as requested. I have also managed to get an application onto the pv through Ken Roach advice.
Attached Images
File Type: jpg Screen Dump.jpg (50.9 KB, 55 views)
  Reply With Quote
Old March 18th, 2013, 11:11 AM   #6
dmargineau
Lifetime Supporting Member
United States

dmargineau is offline
 
dmargineau's Avatar
 
Join Date: Dec 2011
Location: Midwest
Posts: 2,385
Steven,
If you have the Runtime application copied within the terminal's Internal Storage as per Ken's suggestion, why do you want to download to the terminal?!
The issues you are experiencing are related to the Revision Level of the FactoryTalk View software you are running, 5.10, and the Revision Level of the Firmware running on on the PanelView Plus 6 terminal.
You will not be able to "connect" the FTVS 5.10 software to the PanelView Plus 6 hardware!
Since you cannot "downgrade" the PanelView Plus 6 firmware the only option you have is to upgrade the FactoryTalk View Studio to Revision 6.10.
Until then, "handle" the Runtime application via removable media as you have already done.
When running FTVS 6.10, download choosing the PanelView Plus icon and not the rest of the HMI system's components.

Last edited by dmargineau; March 18th, 2013 at 11:13 AM.
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
FT View Studio - Displays kandymann LIVE PLC Questions And Answers 5 February 20th, 2012 11:08 AM
AB FT View SE studio anhkhoi LIVE PLC Questions And Answers 5 August 23rd, 2009 03:26 PM
OPC server in FT View SE Abdul_Marlin LIVE PLC Questions And Answers 4 July 8th, 2009 05:36 PM
Fanuc 9030 firmware upgrade problem rainbow_elec LIVE PLC Questions And Answers 2 August 30th, 2008 09:46 AM
Panel View 550 firmware upgrade from DH485 to Df1 communication zmaher LIVE PLC Questions And Answers 1 August 17th, 2006 06:22 AM


All times are GMT -5. The time now is 09:57 AM.


.