You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
Thread Tools Display Modes
Unread November 13th, 2019, 11:33 AM   #1
CesarTamayo
Member
Mexico

CesarTamayo is offline
 
Join Date: Nov 2019
Location: Mexico
Posts: 2
Exclamation Crimson 3.1 Crashes Shell Application

Hello all,

In the last week, I start to work with a CR3000-1500 panel. After some time of work (few minutes or even hours) in the application, Crimson 3.1 (Gold Build 3113.000) crashes showing a window: Shell Application not Response. After that, Crimson 3.1 stops and close. At restart Crimson 3.1 and open the application shows the same error again.
At beginning, I think that was a problem with my PC (Windows 7 Pro 64-bit), then I installed the software in other PC (windows 10 Home), few hours again the same result.

The worst is that application is impossible to open again (I lost all my work 3 times) and I really desperate.

When I try to open the application on a third PC, Crimson shows a error with Microsoft Net Frameworks in the application and is not possible to open.

When I upload the application directly from the panel, the application opens fine, but inmediatly crashing again.

Any suggestion???

Thanks in advance.

Last edited by CesarTamayo; November 13th, 2019 at 11:40 AM.
  Reply With Quote
Unread November 13th, 2019, 03:03 PM   #2
gclshortt
Member
Canada

gclshortt is offline
 
gclshortt's Avatar
 
Join Date: Dec 2014
Location: Cobourg
Posts: 2,953
http://www.plctalk.net/qanda/showthread.php?t=64088

The above thread may help you out.
Try using a 32-bit computer instead of a 64 bit.
Regards,
__________________
Garry
https://www.accautomation.ca
Connect with us on Facebook: facebook.com/accautomation/
  Reply With Quote
Unread November 13th, 2019, 11:52 PM   #3
OkiePC
Lifetime Supporting Member
United States

OkiePC is offline
 
OkiePC's Avatar
 
Join Date: Mar 2005
Location: ENE of Nowhere Oklahoma
Posts: 10,329
It is possible to end up with some corruption in your Crimson database file (even by no obvious fault of your own). I have done this to myself 2 or 3 times in ten years. There are also a couple of ways that I can repeatably cause Crimson to crash without corrupting the database.

My suggestions:
1. CTRL+S is your friend. Save As with a new name can be useful if you are doing something out of the ordinary and you want to store a fresh jumping off point that you can revert back to.

2. Open the "trouble" application. Open a new instance of Crimson. Copy the components from the "trouble" file to the fresh new file, avoiding any that you suspect being problematic. Repeat step 1 during this process. Note that you can drag and drop between two instances most objects, but things like comms settings may have to be set manually.

More than once I have bailed myself out of trouble using suggestion 2, and it is pretty quick to get that done. Once you have the new file created, save it, then rebuild manually the items that were skipped as suspicious.

Things that can crash Crimson: Smart duplicate. It seems to get worse and worse with each new release. I have gotten to the point where I don't use it any more. Sometimes smart duplicate will increment the address of the source tag and not create a new tag. You won't see that until you click away from it and then back. That's right, the tag you are making a duplicate of gets fubarred and you might not even notice until you change the view and then go back and look. One time I did this to about 30 different tags and then dumped it into a running HMI and all my numbers were whacked (they were pointing to the wrong PLC addresses!).

When this happens, and if I keep chugging along, I will notice that the UI will start to hiccup occasionally (hesitate) from that point forward. When I see that start to happen, I stop and save my work, close Crimson and re-open it. This glitch has existed since early versions of Crimson 3.0. If I shut 'er down early into this hesitation state, I can usually avoid a crash. I have also seen Crimson hang for as long as 10 minutes and then recover long enough for me to save my work, then kill it and restart it.

I usually have three or four other things to work on and occupy me for at least long enough to give it a chance to unjam itself.

Deleting multiple tags all at once. If I am deleting a folder full of tags, I will CTRL+S first, or open the folder and select a few at a time several times. I see this when I am deleting more than five or six tags at a time. Why would a person need to delete that many tags? I often start from a working application that has most of all of the bells and whistles I need, then go back and blow away stuff that doesn't apply to the new program I am working on.

I know there are other things that have caused crashes, but none come to mind at this late hour. If I think of them, I will revisit this thread.
__________________
It's not all the variables I am most concerned with, it's the undiscovered constants.

Last edited by OkiePC; November 14th, 2019 at 12:00 AM.
  Reply With Quote
Unread November 19th, 2019, 12:20 PM   #4
CesarTamayo
Member
Mexico

CesarTamayo is offline
 
Join Date: Nov 2019
Location: Mexico
Posts: 2
Thank you guys for all replies.

I begin a new application, I noticed problems with widgets. Sometimes all the objects in the screen disapear, after that, the problem again. I think that is a similar failure as the smart duplicate.

Actually, I do not use widgets and just put legacy primitives.

The problem has disapear.
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
Red Lion Crimson 3.1 CR/LR in complex code return string uwpltd@gmail.com LIVE PLC Questions And Answers 2 May 29th, 2019 04:34 AM
Crimson 3.1 PLC Tags in Complex Expressions EngiTay LIVE PLC Questions And Answers 2 May 16th, 2019 04:27 PM
How to to connect RSLOGIX5000 PLC application with Vijeo Citect SCADA Application mail2jkv LIVE PLC Questions And Answers 5 March 7th, 2017 01:34 PM
SMC log error in Application Server 3.1 for ControlLogix Tag Controls_Fan LIVE PLC Questions And Answers 0 March 24th, 2011 06:18 PM
Intouch 10.1 Application Manager PdP LIVE PLC Questions And Answers 2 November 19th, 2010 03:57 PM


All times are GMT -5. The time now is 04:43 AM.


.