You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
Thread Tools Display Modes
Unread September 18th, 2014, 03:02 PM   #1
Steve Etter
Lifetime Supporting Member + Moderator
United States

Steve Etter is offline
 
Steve Etter's Avatar
 
Join Date: Apr 2002
Location: Morristown, TN
Posts: 949
RSLinx and a New PC based HMI

I am working on a new Touchscreen PC, Windows 7 Professional, where I am installing FactoryTalk View ME Station to interface with a CompactLogix PLC. Everything is good with one exception Ė I canít establish communication with my laptop where I have developed my FTView application. Consequently, I can't directly download my application directly to the HMI. Here is what I have:
1) The laptop, PLC, and new HMI are all connected via a single Hirschmann Managed Switch
2) The Laptop, PLC, and new HMI are all configured to a common IP address range.
a. Laptop: 172.XXX.YYY.16; 255.255.254.0
b. PLC: 172.XXX.YYY.180; 255.255.254.0
c. Laptop: 172.XXX.YYY.181; 255.255.254.0
3) From the laptop and HMI can ping each other successfully.
4) The application on the HMI (loaded via a Flash Drive) successfully interfaces with the PLC.
5) The RSLinx Classic and RSLinx Enterprise on the laptop both recognize the PLC
6) Neither Classic or Enterprise on the laptop recognizes the HMI
7) RSLinx Enterprise on the HMI does not recognize the laptop.
8) Windows Firewall is 100% disabled.
This is the same laptop I use all over the plant to communicate with multiple PLCs and HMIís on various networks. I frequently have to change IP address ranges so Iím very familiar with getting those lined up. Iíve started up and commissioned a fair number of Logix5000 PLCs and PanelView HMIs, so again, Iím pretty familiar with how to do that. What I havenít done (before now) is to have started with a fresh PC and brand new version of FactoryTalk View. I suspect Iím missing something pretty simple here with respect to configuring Windows and/or Security in the new HMI.

Anybody had this problem or know what Iím missing?

Thanks in advance.
  Reply With Quote
Unread September 18th, 2014, 03:21 PM   #2
baldone
Member
United States

baldone is offline
 
Join Date: Feb 2011
Location: Wisconsin
Posts: 203
Be sure to check IP and mask in the HMI. In particular look at the mask for typos.

Make sure you have the EDS stub for the HMI installed on the laptop.

On edit: I see it's ME station on a PC. Not sure if or how that shows up on RSLinx.

Last edited by baldone; September 18th, 2014 at 03:23 PM.
  Reply With Quote
Unread September 18th, 2014, 03:39 PM   #3
Ken Roach
Lifetime Supporting Member + Moderator
United States

Ken Roach is offline
 
Ken Roach's Avatar
 
Join Date: Apr 2002
Location: Seattle, WA
Posts: 14,996
When you have a PanelView Plus, it's the RSLinx Enterprise runtime on the PV+ with its Ethernet driver that is recognized in browses by other computers with RSLinx Enterprise. Sometimes people delete that driver when they are using serial comms to a controller, and are surprised to find that the PV+ isn't visible on Ethernet anymore.

If you plan to download new runtimes to this computer using RSLinx Enterprise and the FactoryTalk View File Transfer Utility, it's the RSLinx Enterprise runtime you need to get working.

Try this: Go into the RSLinx Enterprise configuration for the Ethernet driver on the touchscreen computer and check the "Listen on EtherNet/IP Encapsulation Ports" checkbox. It's on the "Advanced" tab.

You might have to access this via the FactoryTalk Administration Console if you don't have FactoryTalk View Studio on the touchscreen PC. Remember that you're using the Local FactoryTalk Directory, not the Network Directory, when running an ME project.
  Reply With Quote
Unread September 18th, 2014, 04:04 PM   #4
Steve Etter
Lifetime Supporting Member + Moderator
United States

Steve Etter is offline
 
Steve Etter's Avatar
 
Join Date: Apr 2002
Location: Morristown, TN
Posts: 949
Thanks Ken. I found it was not checked. I'll have to wait until tomorrow though to see if it wors - I hosed my laptop and locked myself out. The IT guy says he will fix it tomorrow morning.
  Reply With Quote
Unread September 19th, 2014, 09:31 AM   #5
Steve Etter
Lifetime Supporting Member + Moderator
United States

Steve Etter is offline
 
Steve Etter's Avatar
 
Join Date: Apr 2002
Location: Morristown, TN
Posts: 949
Ok. Well checking the "Listen on EtherNet/IP Encapsulation Ports" checkbox didn't do it. It did change things, however, just not what I needed. Here is what happened:
  1. The application lost communication to the PLC.
  2. RSLinx Classic is able to recognize the PC's existence.
  3. RSLinx Enterprise still does not recongize the PC.
When I uncheck the checkbox, everything goes back to how it was before.

I'm still hunting....
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:46 PM.


.