You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
 
Thread Tools Display Modes
Old January 12th, 2018, 08:45 AM   #1
emong954
Member
Philippines

emong954 is offline
 
Join Date: Mar 2017
Location: Manila
Posts: 5
Lost Ethernet Communications after Windows 10 Update

A few days ago, I was fixing some settings but accidentally set the windows 10 update, and so it did. Yesterday, when I opened my rslinx, i got an error "cannot open rswho...". So i asked a friend, turns out this was caused by the security update for spectre by windows 10 update. And i was advised to uninstall the updates. so i tried, the uninstall was painfully slow and long. anyway, after the uninstall, the rswho worked already. But, the ethernet driver could not see any plc/panelview in the network. I tried to ping the plcs, but i would get: Reply from 192.168.0.50: Destination unreachable. that's my notebook ip.

I tried reinstalling the ethernet driver and even did a system restore before the security update. Still, i cannot connect via ethernet.

Has anyone experienced this, and found the solution?

Also, with a patch cable, my notebook can ping another notebook, connected directly, but the other notebook says "destination unreachable".

I'm might do a reset to factory default on this notebook.
  Reply With Quote
Old January 12th, 2018, 03:17 PM   #2
Bullzi
Lifetime Supporting Member
United States

Bullzi is offline
 
Join Date: Jun 2012
Location: Colorado
Posts: 1,265
This happened to me too. Just uninstall any windows update since the first of the year. I think they were released on 1-5-18.

KB 1071234 | Access Level: Everyone | Date Created: 01/04/2018 | Last Updated: 01/12/2018

Covers how to fix this.
__________________
There is never enough money to do it right but there is always enough money to do it again.
  Reply With Quote
Old January 12th, 2018, 07:58 PM   #3
emong954
Member
Philippines

emong954 is offline
 
Join Date: Mar 2017
Location: Manila
Posts: 5
Quote:
Originally Posted by Bullzi View Post
This happened to me too. Just uninstall any windows update since the first of the year. I think they were released on 1-5-18.

KB 1071234 | Access Level: Everyone | Date Created: 01/04/2018 | Last Updated: 01/12/2018

Covers how to fix this.
this was the first thing i did... i recovered rswho from rslinx.. but the ethernet never worked after.. still as i write this.. i'm still contemplating on a fresh windows 10 reset..

so i'm still hoping more answers coming in..
  Reply With Quote
Old January 12th, 2018, 11:36 PM   #4
MATT116
Member
United States

MATT116 is offline
 
Join Date: Dec 2009
Location: Dallas, TX
Posts: 327
http://www.plctalk.net/qanda/showthread.php?t=113644
  Reply With Quote
Old January 13th, 2018, 08:43 AM   #5
emong954
Member
Philippines

emong954 is offline
 
Join Date: Mar 2017
Location: Manila
Posts: 5
Quote:
Originally Posted by MATT116 View Post
Hi! Thanks for the link. I did uninstall the security updates dated jan 7 to 10 i found. Now all that's left are from dec 2017. I don't recall the KB numbers though.

Now, the one issue I have is the ethernet not working. When connected to a switch, it toggles between "cable unplugged" and ïdentifying network... I tried to lower the speed.. 10mbps full duplex... it's sort of connected but still can't make a good ping.... returns host unreachable.

so i don't know yet... still searching but nearing the point of reinstalling windows 10.
  Reply With Quote
Old January 13th, 2018, 08:47 AM   #6
Bit_Bucket_07
Member
United States

Bit_Bucket_07 is offline
 
Bit_Bucket_07's Avatar
 
Join Date: Feb 2013
Location: Southeast US
Posts: 1,392
Quote:
Originally Posted by emong954 View Post
Hi! Thanks for the link. I did uninstall the security updates dated jan 7 to 10 i found. Now all that's left are from dec 2017. I don't recall the KB numbers though.

Now, the one issue I have is the ethernet not working. When connected to a switch, it toggles between "cable unplugged" and ïdentifying network... I tried to lower the speed.. 10mbps full duplex... it's sort of connected but still can't make a good ping.... returns host unreachable.

so i don't know yet... still searching but nearing the point of reinstalling windows 10.
Before you do that, it might be worthwhile to open Device Manager, delete your Ethernet adapter, and then reboot and allow it to re-install.
__________________
  Reply With Quote
Old January 13th, 2018, 08:49 AM   #7
emong954
Member
Philippines

emong954 is offline
 
Join Date: Mar 2017
Location: Manila
Posts: 5
Quote:
Originally Posted by Bit_Bucket_07 View Post
Before you do that, it might be worthwhile to open Device Manager, delete your Ethernet adapter, and then reboot and allow it to re-install.
Done that a few times already. No luck!
  Reply With Quote
Old January 14th, 2018, 01:37 AM   #8
emong954
Member
Philippines

emong954 is offline
 
Join Date: Mar 2017
Location: Manila
Posts: 5
Here's an update: i checked the physical ethernet port and noticed some wires/contacts were a bit depressed relative to others. I gave i a nudge but accidentally pulled it off its place. Still i thoughr it will have better contact. When i inserted the cable, back to normal. Thank you guys. I did a lot of uninstalling.. so now I will just have to do a fresh install of windows 10. Clean slate, o well.
This thread ca now be closed.
  Reply With Quote
Old January 17th, 2018, 10:27 AM   #9
Firejo
Member
United States

Firejo is offline
 
Firejo's Avatar
 
Join Date: Jun 2008
Location: Redmond, WA
Posts: 906
Actually, there are currently 12 issues related to Microsoft’s release of security updates to mitigate the threat of exploitation of the Meltdown and Spectre vulnerabilities on systems containing certain CPUs. I have one desktop that updated that won’t run RSLinx anymore (the update won’t uninstall) and a laptop that updated and RSLinx wouldn’t run until I uninstalled the update. There are some computers out there that crashed completely after the updates were installed. Rockwell is still looking at the issues and will announce a fix when they find one (if they find one before MS does) however if you have a problem computer and can uninstall the update that is currently the recommended fix. Microsoft will be replacing the problem updates with new ones that don’t break computers. If you can’t uninstall the updates, you’re kinda up a creek without a paddle. MS does have a beta “patch” that one of the test engineers in my office has installed and it worked but it took several hours to install, and things run a little slower now.
The updates that are known to cause issues with RA products (according to the publication that I found) are: KB4058702, KB4056892, KB4056890, KB4056891, KB4056895, KB4056896, KB4056898, KB4054517
__________________
Go Hawks!!!

Last edited by Firejo; January 17th, 2018 at 10:29 AM.
  Reply With Quote
Old January 17th, 2018, 11:21 AM   #10
AustralIan
Member
United Kingdom

AustralIan is online now
 
Join Date: Jan 2013
Location: UK
Posts: 729
Security update to stop rogue software stealing your data causes RSLinx to stop working, eh?

Must be a coincidence.
  Reply With Quote
Old January 17th, 2018, 05:42 PM   #11
Bullzi
Lifetime Supporting Member
United States

Bullzi is offline
 
Join Date: Jun 2012
Location: Colorado
Posts: 1,265
This is a case of the cure is way worse that the illness!!

MS must be thinking that the best way to solve the problem with the chips is to make the computer completely unusable. That way no data can can be stolen if its not being used.
__________________
There is never enough money to do it right but there is always enough money to do it again.
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
Windows 10 / 1747-UIC communications jjamison LIVE PLC Questions And Answers 0 October 5th, 2017 08:04 AM
Windows 10 Save-As functionality Jt92gmc LIVE PLC Questions And Answers 7 July 5th, 2017 09:13 AM
Ethernet Communications between 2 x S7 315 2PN/DP PLCS MorphuisOGrady LIVE PLC Questions And Answers 6 January 16th, 2014 02:57 AM
Uniop HMI on Ethernet UniNet having slow update GaryP LIVE PLC Questions And Answers 0 November 30th, 2005 05:26 PM
how often should I trigger the PID? Ron Beaufort LIVE PLC Questions And Answers 11 February 22nd, 2003 10:57 AM


All times are GMT -5. The time now is 11:50 PM.


.