You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Unread January 27th, 2012, 01:30 PM   #1
asim_rana
Member
Pakistan

asim_rana is offline
 
Join Date: May 2005
Posts: 50
Magelis hmi xbtg4320 and a twido plc twdlcda24drf

DEAR FRIENDS I HAVE A MAGELIS HMI XBTG4320 AND A TWIDO PLC TWDLCDA24DRF. I HAVE FOLLOWING DETAILS:

HARWARE SETTINGS:::
1-I AM USING TWIDOSUIT FOR PLC AND VIJEO DESIGNER FOR HMI.

2-I AM USING DOWNLOADING CABLE FOR HMI "XBTZG935" (PC)USB<------------------>USB(HMI)

3-THE CABLE B/W PLC AND HMI IS "XBTZ9780" (PLC)MINI DIN<----------->RJ45(HMI)
SOFTWARE SETTINGS:::

PLC:
1-OPENED TWIDOSUIT AND IN WORKSPACE OF DESCRIPTION I DRAGGED AND DROPPED TWIDO PLC TWDLCDA24DRF AND CLICKED ON TWIDO PLC AND SETTED THE TYPE MODBUS AND ADDRESS AS 2 (Slave).

2-SIMILARLY I DRAGGED AND DROPPED MAGELIS HMI AND MADE ITS SETTINGS AS MODBUS Master AND ADDRESS 0 (Master)

3- I JOINED THE MIN DIN CONNECTOR OF PLC WITH THE HMI, SO ON WORKSPACE IT SHOWED ME "MY NETWORK 1, 19200", PARITY=EVEN, STOP=1, DATA BITS=8

4-IN PROGRAMMING OF PLC I DIRECTLY ENERGIZED %M0 --------------------------------(%M0)

5- I DOWNLOADED THIS PROGRAM ON PLC.

HMI::

1-OPEN VIJEO DESIGNER CREATED A PROJECT WITH NETWORK AS MODBUS RTU AND SLAVE EQUIPMENT

"2" AS TWIDO PLC ADDRESS IN ABOVE PLC SETTINGS IS MADE ONE (CHECK STEP 1), XBTG MODEL=XBTG4320,

2-SETTINGS ARE ALSO LIKE THEIR IN PLC BAUD RATE 19200, PARITY=EVEN, STOP=1, DATA BITS=8, COM PORT=COM2

3-CREATED A VARIABLE WITH TYPE=DISCREAT, DEVICE ADDRESS %M0,SOURCE=EXTERNAL

4-I M JUST CREATED A CIRCLE AND IN ITS VISIBLE TAB I CHECK BLINKING ANIMATION AND AND SELECTED THE VARIABLE %M0 WHICH I CREATED ABOVE
CONCLUSION:

I HAVE DIRECTLY ENERGIZED %M0 FROM PLC AND ALSO CREATED A VARIABLE %M0 IN HMI AND TAGGED WITH THE BLINKING CIRCLE AND SELECT COM 2 IN HMI. BECAUSE COM2 IN HMI IS CONNECTING HMI ITSELF AND PLC THROUGH CABLE XBTZ9780 AS I DESCRIBED IN HARDWARE SECTION. NOW WHEN I DOWNLOAD THE PROGRAM IN HMI, THERE IS A CIRCLE BUT ITS NOT BLINKING, AND AFTER SOME SECONDS IT SHOWS TIME OUT NO RESPONSE FROM PLC.

NOW BROTHERS HELP ME OUT WHY THIS IS SO. WHY %M0 IS NOT LINKED
  Reply With Quote
 
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:27 PM.


.