You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
 
Thread Tools Display Modes
Old September 18th, 2018, 05:34 PM   #1
JKam55
Member
United States

JKam55 is offline
 
Join Date: Dec 2017
Location: Ohio
Posts: 3
Factorytalk View SE Local Station Sluggish/Slow Response to SLC 5/05

I am upgrading one of our sites from Rsview32 to Factorytalk View SE Local Station on Win10 and I have the program all set up and switched over but it seems that all of the tag responses are about 3-5 times slower at least than it was with RSView32 (using direct driver).

My setup is this: FTView SE to a SLC 5/05 (1747-L552 32k) PLC. The HMI PC goes straight to the managed switch that the SLC is connected to. The plant itself runs through Devicenet and RIO but we do have one other data collection PC on site talking to the PLC through RSLinx Classic OPC Topic.

Both the SLC and the PC are set for autonegotiation and I have also set all of the (critical) screen displays in FTView SE to below .25 sec refresh rate, compared to the standard 1 sec times. I do not have access to the managed switch settings but I am trying to talk with our IT to see if there is anything they can possibly look at.

The new program does use all HMI tags instead of direct references, which I have heard can cause some delays. From what I am seeing though, the delays seem a lot worse than what would be cause by extra time from HMI tags...

Does anyone have any other ideas for better comms? I feel like I am missing something here.

Thank you in advance for any help.
  Reply With Quote
Old September 19th, 2018, 07:24 AM   #2
gclshortt
Member
Canada

gclshortt is offline
 
gclshortt's Avatar
 
Join Date: Dec 2014
Location: Cobourg
Posts: 2,607
http://www.plctalk.net/qanda/showthread.php?t=110945

The above thread may help you out. It also mentions the slow response.
Regards,
__________________
Garry
https://www.accautomation.ca
Connect with us on Facebook: facebook.com/accautomation/
  Reply With Quote
Old September 19th, 2018, 11:18 AM   #3
JKam55
Member
United States

JKam55 is offline
 
Join Date: Dec 2017
Location: Ohio
Posts: 3
Thanks Garry.

After reading through a bunch of posts and looking into the plant a bit more, I think the issue is originating from too many connections to the SLC Ethernet.

I removed all Ethernet connections and just tied the FTView SE PC and the SLC straight to an unmanaged switch by themselves and the response time improved dramatically.

I have to wait until later but the diagnostic file for CH1 Ethernet on the SLC is not defined so I am going to download to the PLC and monitor that file but I have a pretty good feeling that's what my issue is. I am not very familiar with how the direct driver works in RSView32 but it is definitely faster to the SLC than the new RSLinx Enterprise connection with FTView SE... Either that or it just simply doesn't bog the system down as much.

I am not exactly sure what can help me out in this situation though if we stick to the SLC unless I change to a L553 64K processor to increase the connection amount... I will have to take a look at some other possible solutions.

Last edited by JKam55; September 19th, 2018 at 11:27 AM.
  Reply With Quote
Old September 19th, 2018, 04:07 PM   #4
JKam55
Member
United States

JKam55 is offline
 
Join Date: Dec 2017
Location: Ohio
Posts: 3
Well in case anyone reads this, it looks like my problem did involve the Ethernet comms with the SLC 5/05.

There is a bit in the processor status Ch1 settings S:2/15 that, if enabled, only allows one Ethernet connection to be processed per scan, or something along those lines. I disabled the bit to allow multiple connections to be processed per scan and the difference was very noticeable! The response from the HMI is very quick now and I didn't notice any real change in the PLC scan time either.
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
Problems with FactoryTalk SE Local 9.0 upgrade GlenGineer LIVE PLC Questions And Answers 5 June 12th, 2018 02:13 PM
VNC Server FactoryTalk View SE elmatador LIVE PLC Questions And Answers 3 March 21st, 2017 07:09 PM
Updating FactoryTalk View SE Local Station zacslade LIVE PLC Questions And Answers 7 July 5th, 2016 02:10 PM
FactoryTalk SE Local Alarms vettedrivr LIVE PLC Questions And Answers 3 December 1st, 2014 03:17 PM
RS Linx Classic Read Only ronman LIVE PLC Questions And Answers 26 October 11th, 2013 09:44 AM


All times are GMT -5. The time now is 11:46 AM.


.