You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

Reply
 
Thread Tools Display Modes
Old July 21st, 2004, 11:07 PM   #1
nards656
Member
United States

nards656 is offline
 
nards656's Avatar
 
Join Date: Jul 2004
Posts: 3
Allen Bradley PanelView Plus 1000 and SLC 5/03

Without going in to a lot of detail, I'm trying to get an AB PV+ 1000 to talk to the DF1 serial port (Channel 0) on a SLC 5/03. Does anyone out there have any experience with this? If so, I'll offer more detail. A response by 7 AM Eastern Standard on July 22 would be a marvelous thing

Bernard
  Reply With Quote
Old July 22nd, 2004, 03:03 AM   #2
Ken Roach
Lifetime Supporting Member + Moderator
United States

Ken Roach is offline
 
Ken Roach's Avatar
 
Join Date: Apr 2002
Location: Seattle, WA
Posts: 16,694
It's not difficult; I have done it lots of times.

The cabling is a straight-through RS-232 serial cable. The PanelView has a "DCE" type serial port and the SLC-5/03 has a "DTE" type serial port, so they don't need a "null modem" cable.

The RSLinx Enterprise DF1 driver configuration is a little more complicated. Make sure that you can browse from your PC to the SLC-5/03 serial port with this driver, before you copy the Local RSLinx Enterprise configuration to the Target tab in the RSLinx Enterprise GUI inside RSView Studio.

Again; you need to configure the Target tab in RSLinx Enterprise so that the PV+ terminal knows how to communicate to your SLC-5/03. The easiest way is to use the Local tab to prove the communications path, then copy that over to the Local tab with the "copy" button.

Make sure that the serial framing and DF1 protocol settings on the SLC-5/03 and the PanelView Plus are both the same. Pay special attention to Error Checking; SLC's use CRC error checking by default, but RSLinx Enterprise uses BCC error checking by default.
  Reply With Quote
Old July 22nd, 2004, 08:34 AM   #3
nards656
Member
United States

nards656 is offline
 
nards656's Avatar
 
Join Date: Jul 2004
Posts: 3
I'm using the Allen Bradley 2711-NC13 cable to try to do this. It's the correct cable from my understanding of the documentation, and it's the same cable I'm using to download from my PC to the PV+. Is the cable my problem, by any chance? It's a good cable, but is it the wrong one?

I'm screwing something up, here, and can't seem to find out what.

Thanks so much for your answer.

Bernard
  Reply With Quote
Old July 22nd, 2004, 01:03 PM   #4
Ken Roach
Lifetime Supporting Member + Moderator
United States

Ken Roach is offline
 
Ken Roach's Avatar
 
Join Date: Apr 2002
Location: Seattle, WA
Posts: 16,694
Yes, that cable will work. There has to be something wrong with your RSLinx Enterprise configuration.

You really should get a CompactFlash card for program transfer; it's painfully slow to do that over RS-232.

Post more info about the symptoms of the communication error, and about your RSLinx Enterprise configuration !

(it's also during business hours for RSI technical support if you don't want to wait for a forum discussion of a simple configuration issue.)
  Reply With Quote
Old July 22nd, 2004, 06:49 PM   #5
nards656
Member
United States

nards656 is offline
 
nards656's Avatar
 
Join Date: Jul 2004
Posts: 3
I do have the CF card; it is definitely faster.

We've been on the phone with RSI tech sup for most of three hours; my local AB people have done their best and are bringing in the district PLC guy tomorrow.

While I'm not a total geek, I'm no fool either, and AB really needs to do a better job of documenting all their "comms" combinations.

I really appreciate your offer of help, if I get a chance later tonight I'll try to describe better. The key issue is that NOTHING results in a satisfactory comm between PV+ and SLC. All the ports are good, all the cables are good (for some comms), and all the settings match, but it just doesn't talk.

I'm normally of the mindset that I'm doing something wrong for the first two days. After that, I pretty well know I've tried every possible iteration and it's no longer my fault.

I'm usually right :-)

I'll let you know one way or another how tomorrow goes. Thanks again.

Bernard
  Reply With Quote
Old May 13th, 2011, 10:41 PM   #6
jk1981
Member
United States

jk1981 is offline
 
Join Date: May 2011
Location: usa
Posts: 9
What type of cf card can be used.

Please and thank you
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
SLC 505/PanelView 1000 ttran LIVE PLC Questions And Answers 2 August 6th, 2004 02:49 PM
Buiding a PLC Trainer Using Allen Bradley LIVE PLC Questions And Answers 6 July 17th, 2004 03:13 PM
Panelview 1000 Security AGIESKE LIVE PLC Questions And Answers 2 April 16th, 2004 01:13 PM
Communication between PanelView 1000 and SLC 5/04 RP LIVE PLC Questions And Answers 50 December 9th, 2003 01:50 PM
Display String file on PanelView 1000 wa5yom LIVE PLC Questions And Answers 33 September 15th, 2003 11:53 AM


All times are GMT -4. The time now is 02:38 PM.


.