You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

Reply
 
Thread Tools Display Modes
Old May 27th, 2008, 05:53 AM   #1
matt_sd
Member
Australia

matt_sd is offline
 
Join Date: Jan 2007
Location: Australia
Posts: 96
rockwell Devicenet Error 91 - VSD interference

Hi guys,

I have a problem, a Compact logix PLC with 20 node point all within 20 metres, 121 ohm resistor at each end, network works fine.

Now when a VSD starts (seperate to the devicenet network), I get the error 91 on devicenet scanner. Stop the drive, a toggle of the 24VDC devicenet supply and all ok again until the next time.

I have checked connections. I read the rockwell devicenet manual and it said that the 0V of the devicenet 24VDC supply and the devicenet shield must be connected to earth (only one connection and close to centre of the network). There was to earth connection to the ground or the 0V. I connected these and the same occurs when the drive starts. I also checked the resisters.

I dont know what else to do, the signal cables comming into the panel are shielded to earth at one end,

The nodes are compact block analogue/digital inputs/outputs and Danfoss VFD drives (the starting of these donesn't cause and devicenet errors)

Any help appreciated as stuck!!!

Thanks

Matt
  Reply With Quote
Old May 27th, 2008, 08:33 AM   #2
andrewke1
Member
Australia

andrewke1 is offline
 
Join Date: Apr 2007
Location: Melbourne
Posts: 11
With the CompactLogix you should have a 1769-SDN....

Error 91 Bus Off Bus off condition detected on itegral DeviceNet port.
Check the DeviceNet connections & physical media integrity.
Check system for failed slave devices or other possible sources
of network interference. Check the Baud Rate.

The drive may be spiking one of your field devices.

In RSLogix5000 go to the 'Controller Tags' check the Module Status Register.

'Local:1:I.StatusRegister' will give you some basic information.

'Local:1:I.Status.DeviceFailureRegister' might help you to narrow it down to a particular node if that is where the problem lies.
From AB..."The bit position of each of the 64 bits that make up a given status table directly correspond to the node address of a device."

Hope this helps.

Last edited by andrewke1; May 27th, 2008 at 08:36 AM.
  Reply With Quote
Old May 27th, 2008, 09:31 AM   #3
OkiePC
Lifetime Supporting Member
United States

OkiePC is offline
 
OkiePC's Avatar
 
Join Date: Mar 2005
Location: ENE of Nowhere Oklahoma
Posts: 10,939
Also, check the wiring of the VFD that causes the fault. Make sure its ground wire is connected between the drive and motor. Consider using shielded motor cable to capture and drain noise from the motor leads.
__________________
You can choose a ready guide in some celestial voice. If you choose not to decide you still have made a choice.
  Reply With Quote
Old May 27th, 2008, 09:54 AM   #4
widelto
Member
Colombia

widelto is offline
 
widelto's Avatar
 
Join Date: Jul 2005
Location: Barranquilla, Colombia
Posts: 3,016
Matt:

It seems that the problem your having is basically electrical noise, do you have ferrite beads installed in all devicenet conections ( in and out)?, I have a system with more devices connected 26 in less space and works fine. Though error 91 is related to bus connection, please try to read info about noise reduction, like grounding power supply an so on. Also there are two program samples that you can use in order to diagnose your network, they are located in sample code library of www.ab.com page.
__________________
My two cents.
  Reply With Quote
Old May 27th, 2008, 10:06 AM   #5
PLC GURU
Lifetime Supporting Member
United States

PLC GURU is offline
 
Join Date: Dec 2007
Location: NY
Posts: 121
I dont use CLX or that particular drive (We use PLC5 & SLC500& AB drives) Anyways we had a similar problem and had to put a properly sized RC filter on the drive. We had AB come in and analyze the issue they said that 2 things were happening 1-the drive was "transmitting" noise, and the D-net comm was picking it up, killing the network and 2- everytime the EMF field collapsed (motor stopped) it sent a huge voltage spike knocking out the whole network.
Dont know if this is the same issue your having but I hope it helps.
  Reply With Quote
Old May 27th, 2008, 01:59 PM   #6
matt_sd
Member
Australia

matt_sd is offline
 
Join Date: Jan 2007
Location: Australia
Posts: 96
Thanks for your replies.
I have been going through them all.

With the VSD to motor grounding, I did see that the cable from the VSD to motor was screened and was connected at the VSD end to ground. Does this mean that the motor end should not be connected to ground (as you should only ground one end)?

Back to grounding, so the centre devicenet cable (shield) should this be connected to ground and also the 0VDC of the devicenet power to ground?

PLC GURU, did your RC filters come from the drive supplier?

Thanks

Matt
  Reply With Quote
Old May 28th, 2008, 07:24 AM   #7
PLC GURU
Lifetime Supporting Member
United States

PLC GURU is offline
 
Join Date: Dec 2007
Location: NY
Posts: 121
Allen-Bradley did supply the filter, but it wasn't an "AB" branded filter . your drive supplier may be able to specify what you need.
  Reply With Quote
Old July 2nd, 2014, 07:40 AM   #8
regentb
Member
Canada

regentb is offline
 
Join Date: May 2008
Location: Cambridge
Posts: 4
devicenet fault 91

I've got a compact logix and a 1769 SDN. Everything works fine through out the day. Ever morning when I come in I have a Fault 91 on my scanner. It doesn't happen at all during the day while I am running only over night with the machine is down.

Has anyone else ever come across this issue before. Any help would be greatly appreciated.
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
DEVICENET, what am I missing rsdoran LIVE PLC Questions And Answers 10 October 14th, 2011 05:19 PM
Rockwell Allen Bradley Programming Software, RSLogix 5, RSLogix 500, RS Linx, RSLogix vvcd LIVE PLC Questions And Answers 21 September 24th, 2009 11:04 PM
DeviceNet Project Jimmie_Ohio LIVE PLC Questions And Answers 5 October 19th, 2005 05:03 PM
DeviceNet Adapter Questions Peter Nachtwey LIVE PLC Questions And Answers 9 August 23rd, 2004 04:02 AM
DeviceNet rsdoran LIVE PLC Questions And Answers 6 September 5th, 2003 05:35 AM


All times are GMT -4. The time now is 03:41 PM.


.