You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
 
Thread Tools Display Modes
Old January 11th, 2017, 09:08 AM   #1
Justinlane03
Member
Canada

Justinlane03 is offline
 
Join Date: Jan 2014
Location: High Level
Posts: 2
.PBA to MER Conversion Failure

Hey all,

So I'm trying to import and old Panelbuilder32 application into FactoryTalk view Studio. I've had success doing this in the past, although not a perfect conversion. When I choose my .PBA file, FTV Studio starts to go through the import process, then just comes up "Unable to open file". On other machines, we are getting a "Server threw an exception'. On the phone with the rockwell guys, they figure an external font was causing the failure, but they are disabled.

The PV application is PV1000 Gray, through RIO Protocol. I am using Panelbuilder 3.83.01, and the FTV Studio software is 8.20. Sorry for leaving out information, just wondering if anyone had any ideas I could try?
  Reply With Quote
Old January 11th, 2017, 09:43 AM   #2
James Mcquade
Member
United States

James Mcquade is offline
 
Join Date: Oct 2007
Location: Tennessee
Posts: 1,743
Welcome to the forum.

my first thought is to ask what version of panelbuilder was the file created on?
older pba files may need to be upgraded to 3.83.01 and saved then converted.
the very old versions have to be upgraded to ver 2.64 ( I think or another version) and then upgraded to 3.83.01. I had to do this a couple of times.

james
  Reply With Quote
Old January 11th, 2017, 03:10 PM   #3
arlenjacobs
Lifetime Supporting Member
Canada

arlenjacobs is offline
 
Join Date: Sep 2014
Location: Kelowna
Posts: 487
same here, my first thought was to save the PBA into version 3.8

First off, create a safe backup of your existing PBA file.
Next to try in PanelBuilder and then resave the PBA. Retry the import after each one:
(1) Export the tags to an Excel file, then delete the entire tag database.
(2) Change the terminal to a PV1000 colour with Ethernet. You'll need to fix up the RIO stuff.
(3) Delete half of the screens. If that doesn't work, try again with the other half deleted.

That should help narrow down where/why you get the error during import. Once you figure that out then you can go back and find a way to import the rest of the project info.
  Reply With Quote
Old January 12th, 2017, 05:22 PM   #4
Justinlane03
Member
Canada

Justinlane03 is offline
 
Join Date: Jan 2014
Location: High Level
Posts: 2
Thanks for the responses guys. I tried deleting the tags, to no avail. Then I deleted half the screens, and the process seemed to get further. Last I deleted everything, and that was the only was to get the file to convert. (Although that doesn't help because we get nothing >.<)

So it seems like its either a combination of tags and screens faulting the conversion. Just doing like arlenjacobs suggested and trying to narrow down what is the problem.
  Reply With Quote
Old January 12th, 2017, 05:37 PM   #5
dmroeder
Lifetime Supporting Member
United States

dmroeder is offline
 
dmroeder's Avatar
 
Join Date: Apr 2006
Location: Vancouver, WA
Posts: 1,804
When the import ultimately fails, does it suggest that a log file was created?

I helped a user find and error on importing and the log file vaguely suggested where the problem was. I don't remember what the log file name was or where it created it though.

edit: If you want, I could try to import it for you like I did for the other user. PM me your email address if you want.
  Reply With Quote
Old January 12th, 2017, 06:40 PM   #6
JaxGTO
Member
United States

JaxGTO is offline
 
Join Date: Apr 2009
Location: Kalieefornia
Posts: 448
I had the same message when I converted an application. I called tech support also and they told me to first import it on a 32 bit machine (I have a Windows 7 32 bit with FTView 8.0) and it worked. Then I wrote an apa and restored it to the 64 bit machine and all was well.
  Reply With Quote
Old January 13th, 2017, 11:48 AM   #7
arlenjacobs
Lifetime Supporting Member
Canada

arlenjacobs is offline
 
Join Date: Sep 2014
Location: Kelowna
Posts: 487
Quote:
Originally Posted by dmroeder View Post
When the import ultimately fails, does it suggest that a log file was created?

I helped a user find and error on importing and the log file vaguely suggested where the problem was. I don't remember what the log file name was or where it created it though.

edit: If you want, I could try to import it for you like I did for the other user. PM me your email address if you want.
I think the log file is in the project folder:
C:\Users\Public\Documents\RSView Enterprise\ME\HMI projects\projectname
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
Migrating FactoryTalk View Projects to Windows 7 64 bit Rob S. LIVE PLC Questions And Answers 27 November 29th, 2015 09:17 AM
Unusual encoder failure modes ? Ken Roach LIVE PLC Questions And Answers 11 October 22nd, 2015 06:56 AM
Factory Talk View Studio ME older .mer that doesnt allow conversion jtashaffer LIVE PLC Questions And Answers 13 April 25th, 2015 05:58 AM
Starter Failure scadadavid LIVE PLC Questions And Answers 13 December 1st, 2012 07:57 AM
PVA to MER conversion gmarowski LIVE PLC Questions And Answers 6 May 27th, 2011 03:37 PM


All times are GMT -5. The time now is 10:16 PM.


.