You are not registered yet. Please click here to register!


 
 
plc storereviewsdownloads
This board is for PLC Related Q&A ONLY. Please DON'T use it for advertising, etc.
 
Try our online PLC Simulator- FREE.  Click here now to try it.

---------->>>>>Get FREE PLC Programming Tips

New Here? Please read this important info!!!


Go Back   PLCS.net - Interactive Q & A > PLCS.net - Interactive Q & A > LIVE PLC Questions And Answers

PLC training tools sale

Reply
 
Thread Tools Display Modes
Old April 15th, 2015, 11:17 AM   #1
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
Failure to upload/go online, ControlLogix 5561

Hi everyone,

I've got a 1756-L61/B, 19.11, and RSLogix is failing to go online or upload to a new program. I have the program that was created from the aborted upload attached, but the old program that I attempted to go online with is too large. The new program does not list all the modules, which include controlnet, ethernet, hydraulic, DC Input, AC in and out, and two flex i/o in the operator consoles.

The error I'm getting is 806-8004280A, and the entire error log looks like:

Uploading project from controller 'Charles_Ingram_1257_18' into file Charles_Ingram_1257_18.ACD...
Preparing the Database...
Uploading all Data Types...
Uploading all Controller Tags...
Uploading Device, Extended Device, and Memory Objects...
Uploading all Add-On Instructions...
Uploading all Programs...
Uploading program 'MainProgram'
Uploading all 'MainProgram' Tags...
Uploading all 'MainProgram' Routines...
Uploading routine 'STI'
Uploading routine 'SKEW_TARGET'
Uploading routine 'WIDTH_AVG'
Uploading routine 'MMI_SCREENS'
Uploading routine 'SEQUENCERS'
Uploading routine 'LUG_SPEED'
Uploading routine 'MMI_MSGNUM'
Uploading routine 'EDGER_FEED'
Uploading routine 'RESAW'
Uploading routine 'HYD_GRADIENTS'
Uploading routine 'TALLY_DATA'
Uploading routine 'LUG_INLK'
Uploading routine 'TARGET_FETCHERS'
Uploading routine 'LUG_POSITION'
Uploading routine 'FEED_TABLE'
Uploading routine 'OILER_SYSTEMS'
Uploading routine 'HYD_FAULTS'
Uploading routine 'SKEW_INIT'
Uploading routine 'MODE_BITS'
Uploading routine 'SKEW_NEAREND_SECOND'
Uploading routine 'MOTORS'
Uploading routine 'MMI_DISPLAY'
Uploading routine 'MEASURE_SPEED'
Uploading routine 'LUG_DRIVE'
Uploading routine 'INFEED'
Uploading routine 'HYD_HYD100'
Uploading routine 'BIT_SHIFT'
Uploading routine 'PRESSROLLS'
Uploading routine 'WIDTH_COUNTS'
Uploading routine 'MINIMUM_CUT'
Uploading routine 'MISC_ITEMS'
Uploading routine 'MMI_CALIB'
Uploading routine 'PREPOS_DN'
Uploading routine 'HYD_JOG'
Uploading routine 'OFFSETS'
Uploading routine 'MAIN_ROUTINE'
Uploading routine 'FETCHER_OVERRIDE'
Uploading routine 'WIDEST_EYE'
Uploading routine 'HYD_MAIN'
Uploading routine 'CHANGE_SAWS'
Uploading routine 'MMI_MSGDET'
Uploading routine 'FETCH_HOME'
Uploading routine 'OPTIMIZER_DATA'
Uploading routine 'CAL_FAIL'
Uploading routine 'EDGER_INIT'
Uploading routine 'GRAPH_GAP'
Uploading routine 'MMI_OVERRIDES'
Uploading routine 'MMI_STATUS'
Uploading routine 'RESAW_DIVERTER'
Uploading routine 'BOARDS_ONE'
Uploading routine 'NEXT_BOARD'
Uploading routine 'HYD_POSITION'
Uploading routine 'SKEW_FAREND_FIRST'
Uploading routine 'HYD_CONTROLS'
Uploading routine 'PREPOS_UP'
Uploading routine 'TARGET_SAWS'
Uploading routine 'SKEW_END'
Uploading routine 'HYD_CALIB'
Uploading routine 'ELECTROCAM'
Uploading all Modules...
Error: No port was found with the given port number.
Error: Failed to upload modules.
Complete - 2 error(s), 0 warning(s)

It will tell me that RSLogix is being taken offline, and thats it.

I did notice that the old program has the controller revision as 19.52, which is different than what's coming up when I try to do an upload to a new program.

Any ideas on the steps I should take? I can't take the machine offline during the day, but we may be able to do it tonight. Do you think it'll upload in Program mode?
Attached Files
File Type: zip NewFailedUploadProgram.zip (215.0 KB, 8 views)
  Reply With Quote
Old April 15th, 2015, 11:58 AM   #2
dmargineau
Lifetime Supporting Member
United States

dmargineau is offline
 
dmargineau's Avatar
 
Join Date: Dec 2011
Location: Midwest
Posts: 2,385
19.52 is a Redundant System firmware.
Refer to
http://literature.rockwellautomation...m523_-en-p.pdf

for information regarding the Logix Redundancy functionality.
  Reply With Quote
Old April 15th, 2015, 12:22 PM   #3
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
Thanks. Can you explain why the upload would be showing 19.11 though?
  Reply With Quote
Old April 15th, 2015, 02:09 PM   #4
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
Ok, I've tried connecting through Ethernet and it's coming up on RSLinx, but I'm still getting the same error, No Port Was Found With the Given Port Number.

I made sure to add both the IP for the Ethernet module and the Ethernet "Optimizer" that is listed in the original program.

I read through the manual for the 19.052 firmware, but haven't found anything relevant to this problem.
  Reply With Quote
Old April 15th, 2015, 02:25 PM   #5
dmargineau
Lifetime Supporting Member
United States

dmargineau is offline
 
dmargineau's Avatar
 
Join Date: Dec 2011
Location: Midwest
Posts: 2,385
https://rockwellautomation.custhelp....il/a_id/676537
  Reply With Quote
Old April 15th, 2015, 02:35 PM   #6
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
Here are my RSLinx logs for when I was trying to upload.

04/15/15 13:44:07 12.57.18.1 Can't read port type: read from Harmony property bag failed
04/15/15 13:44:08 12.57.18.1 Attempting first connection, protocol = CSPv4
04/15/15 13:44:09 12.57.18.1 Unable to establish TCP connection to the Ethernet Interface
04/15/15 13:44:09 12.57.18.1 [10061] Connection refused
04/15/15 13:44:09 12.57.18.1 Device refused a CSPv4 connection, retry using EtherNet/IP
04/15/15 13:44:09 12.57.18.1 Attempting first connection, protocol = EtherNet/IP
04/15/15 13:44:09 12.57.18.1 Device has accepted the EtherNet/IP connection
04/15/15 13:50:46 12.57.18.1 Error receiving data from the Ethernet Interface
04/15/15 13:50:46 12.57.18.1 [10054] Connection reset by peer
04/15/15 13:50:46 12.57.18.1 EtherNet/IP connection has been lost
04/15/15 13:50:56 12.57.18.1 Attempting to reestablish a lost EtherNet/IP connection
04/15/15 13:50:56 12.57.18.1 Device has accepted the EtherNet/IP connection
04/15/15 14:01:52 12.57.18.2 Can't read port type: no Harmony port for this IP address
04/15/15 14:04:06 12.57.18.2 Attempting first connection, protocol = CSPv4
04/15/15 14:04:07 12.57.18.2 Unable to establish TCP connection to the Ethernet Interface
04/15/15 14:04:07 12.57.18.2 [10061] Connection refused
04/15/15 14:04:07 12.57.18.2 Device refused a CSPv4 connection, retry using EtherNet/IP
04/15/15 14:04:07 12.57.18.2 Attempting first connection, protocol = EtherNet/IP
04/15/15 14:04:07 12.57.18.2 Device has accepted the EtherNet/IP connection
04/15/15 14:04:07 12.57.18.2 Can't set port type to 288: no Harmony port for this IP address
  Reply With Quote
Old April 15th, 2015, 02:49 PM   #7
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
I've read through that KB article, and it is asking me to upload or download, but when I choose to upload to a new file, it fails with the error I mentioned above.
  Reply With Quote
Old April 15th, 2015, 02:52 PM   #8
dmargineau
Lifetime Supporting Member
United States

dmargineau is offline
 
dmargineau's Avatar
 
Join Date: Dec 2011
Location: Midwest
Posts: 2,385
If this is a redundant system, most likely the controller is secured.
This is the last "bullet point" of the RA Knowledgebase TechNote 676537 (Access Everyone- Link in Post #5)

"...RSL5K will not upload, download or go online with a secured controller. Unsecure the controller and try again...."
  Reply With Quote
Old April 15th, 2015, 02:52 PM   #9
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
Ok, Let me figure out how to unsecure it.
  Reply With Quote
Old April 15th, 2015, 03:03 PM   #10
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
Also, it's got the redundant firmware, but the system isn't redundant. It's only got one controller, and redundancy is turned off. I've gone through every module on RSLinx and everything is setup for all users, no log on or pws, and I'm still getting the same error on upload.
  Reply With Quote
Old April 15th, 2015, 03:10 PM   #11
dmargineau
Lifetime Supporting Member
United States

dmargineau is offline
 
dmargineau's Avatar
 
Join Date: Dec 2011
Location: Midwest
Posts: 2,385
What RSLinx revision are you running?
  Reply With Quote
Old April 15th, 2015, 03:11 PM   #12
Ken Roach
Lifetime Supporting Member + Moderator
United States

Ken Roach is offline
 
Ken Roach's Avatar
 
Join Date: Apr 2002
Location: Seattle, WA
Posts: 14,264
For reasons that are unclear, RA added a leading zero to controller firmware revisions, but still allows many software products and user manuals to refer to the minor revision without the leading zero.

The ".5 and above" rule still applies to redundant firmware, which is why we know that 19.011 is nonredundant and 19.052 is redundant.

The offline file being set up for the wrong firmware revision might be an issue. You can experiment with just uploading into a new empty file rather than attempting to correlate with the old file.

The Harmony error may be getting conflated with the Module upload error. I would try doing a full reset of the RSLinx Classic drivers, as described in RA Knowledgebase article 39930 (TechConnect required).

You have my sympathy on that confusion; I just checked the firmware on a controller that a colleague set up but I have on a bench in my office. It's a single-controller, 4-slot application, and yet he loaded 20.054 firmware (for Redundant controllers).
  Reply With Quote
Old April 15th, 2015, 03:34 PM   #13
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
3.71
  Reply With Quote
Old April 15th, 2015, 03:39 PM   #14
Jasondelane
Member
United States

Jasondelane is offline
 
Jasondelane's Avatar
 
Join Date: Mar 2015
Location: Florence sc
Posts: 129
Ken, I did an upload to an empty file to doublecheck, and it's saying the file is Revision .052, even though the controller isnt set up for redundancy. I'm still getting the error. I'm downloading all the ethernet EDS files just to get that out of the way and make sure RSLinx identifies all the modules. I'm running out of ideas.
  Reply With Quote
Old April 15th, 2015, 03:49 PM   #15
dmargineau
Lifetime Supporting Member
United States

dmargineau is offline
 
dmargineau's Avatar
 
Join Date: Dec 2011
Location: Midwest
Posts: 2,385
If you have a valid TechConnect contract follow the link in Ken's last post.
If you do not, you might want to try clearing the RSLinx cache (Harmony files)

https://rockwellautomation.custhelp....8241/related/1
  Reply With Quote
Reply
Jump to Live PLC Question and Answer Forum

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Topics
Thread Thread Starter Forum Replies Last Post
Online Controllogix via Ethernet djpalaz LIVE PLC Questions And Answers 11 January 2nd, 2008 05:33 PM
SLC500, MicroLogix, ControlLogix, etc. Online Edits. Tharon LIVE PLC Questions And Answers 7 January 19th, 2007 12:53 AM
ControlLogix 5555 redunadancy failure clementaliu LIVE PLC Questions And Answers 0 May 15th, 2006 01:17 PM
ControlLogix 1757-SRM failure ashley LIVE PLC Questions And Answers 14 May 2nd, 2005 08:45 AM
controllogix analog module online range change lucifer LIVE PLC Questions And Answers 2 September 7th, 2004 02:19 PM


All times are GMT -5. The time now is 10:36 AM.


.