Failed to load data types

bigsteve777

Member
Join Date
Dec 2013
Location
The Land Of Chocolate
Posts
25
Running RSlogix Studio 5000 Ver 21. Win 7 64.

I get this error when trying to go online and uploading from PLC.

Uploading project from controller '----------' into file ------------.ACD...
Preparing the Database...
Uploading all Extended Property Definitions...
Uploading all Data Types...
Error: Already exists.
Error: Failed to upload data types.
Complete - 2 error(s), 0 warning(s)

I have updated the .eds files and it still doesn't work. Any suggestions??

Thanks in advance.

 
I found the solution. For some reason this version of Studio 5000 will not allow you to upload unless you have the latest program that is loaded. Good luck if you don't have the latest update of the program. I don't why you are unable to Upload this seem very strange to me. I was give the latest version of the program and was able to go online then. Damn Rockwell!
 
Hello and happy Friday. This is precisely the error that I'm receiving. Rockwell support tells me the program in the control could be corrupt. That's what they said about the last error (different error btw) I had with another Identical controller. It turned out that it was an inherent problem with my v21 software and it took my dealer support (North Coast Electric) to figure that out. Resolved that error with a 21.03 upgrade. @ bigsteve777, have you discovered a solution for this?
My dealer tells me to sign up for a Rockwell support plan but if they can't provide viable solutions then I can't very well justify that.
How does everyone feel about their support?
 
I have luck with our TechConnect plan about 50% of the time (as far as solutions over the phone go). Getting access to the knowledge-base is worth it . Anytime something doesn't seem to be working as it should I always find a work around in the knowledge-base.

On a side note, at least with our reseller. If you have many licenses of Studio 5000 or other Rockwell software they give you the TechConnect for 'free'.
 
I've generally found the support contract to be well worth the money.

The issue you're seeing is a becoming-well-known SNAFU where someone at Rockwell forgot about the differences between major revisions and minor revisions. This blog post explains it well: http://theautomationblog.com/what-you-need-to-know-before-upgrading-to-rslogix-5000-version-20-03/

It's talking about v20, but the same applies to v21. I, and several of my customers, have banned v20 and 21 on any PLC's for that reason.
 
I'm helping a new customer who does not have the .ACD file, their PLC is running v21.11 f/w. I get the EXACT error messages of the OP. I first got the error with my normal system (Win7 Pro x64) running v21.03.01.

Knowing the issues with v21.00 and v21.03, I set up a new VM with v21.00.03. I got the exact same error trying Ethernet, Ethernet/IP and USB connections to the controller. I then upgraded that system to v21.03.00, same error. Then tried v21.03.01 (which according to docs is the same ver of Studio, but I thought what the heck) and got the same error. So from the sounds of it RA has a significant bug w/v21 and my customer is hosed unless they can find the original .ACD file?

Thanks,
-Brad
 
We got the ACD from a systems tech and got connected online. I will be upgrading the customer off v21 (v21.03 to be exact) so they don't have to deal with this BS again in the future.
 

Similar Topics

When i load my client a[plication the following error is recorded in factorytalk view studio log Failed to load data server...
Replies
0
Views
64
Hi All, I create a new project at Factorytalk Local station and a OPC DA server with localhost server. FTView Version :13.00.00 OPC Server...
Replies
3
Views
4,286
Hi, I'm trying to connect with an HMI on one of our machines at work. I have applied the correct pathway to the plc, via the FT Linx communication...
Replies
3
Views
3,267
Hi, I was using FactoryNoTalk and all of the sudden I started receiving this error. I resolved the issue by reverting back to an earlier revision...
Replies
0
Views
1,450
Hi everyone, I'm having a little trouble with this that won't let me move on so i hope you guys can help me, here are the details: I have an...
Replies
2
Views
24,674
Back
Top Bottom