I/O access error, reading

raj87

Member
Join Date
May 2012
Location
banglore
Posts
4
Diagnostic buffer of module CPU 315-2PN/DP

Order No./ Description Component Version
6ES7 315-2EH14-0AB0 Hardware 4
- - - Firmware V 3.2.6
Boot Loader Firmware expansion A 32.9.9

Rack: 0
Slot: 2


Serial number: S C-B9UL53552011


Event 1 of 10: Event ID 16# 2942
I/O access error, reading
P area, byte access, Access address: 390
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
02:07:44.362 PM 06/24/1994


Event 2 of 10: Event ID 16# 2942
I/O access error, reading
P area, byte access, Access address: 374
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
02:07:44.362 PM 06/24/1994
 
A distributed I/O is either disconnected from the network or some configured I/O modules in the HW Configurations is not accessible by the CPU. It might also a programming error.
 
SF and BF fault

I have System fault (SF) on the distributed I/O (IM 153-2). The ON LED is also OFF. Could the IM 153-2 be faulty? if not kindly assist.

Results of the diagnostic buffer is as follows:


Diagnostic buffer of module CPU 315-2 DP

Order No./ Description Component Version
6ES7 315-2AH14-0AB0 Hardware 7
- - - Firmware V 3.3.12
Boot Loader Firmware expansion A 37.12.12

Rack: 0
Slot: 2


Serial number: S C-JOKC49532017


Event 1 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 286
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.905 PM 04/28/2018
(Coding: 16# 2942 017A 0020 011E 0000 0000)


Event 2 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 284
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.905 PM 04/28/2018
(Coding: 16# 2942 017A 0020 011C 0000 0000)


Event 3 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 282
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.904 PM 04/28/2018
(Coding: 16# 2942 017A 0020 011A 0000 0000)


Event 4 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 280
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.904 PM 04/28/2018
(Coding: 16# 2942 017A 0020 0118 0000 0000)


Event 5 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 278
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.904 PM 04/28/2018
(Coding: 16# 2942 017A 0020 0116 0000 0000)


Event 6 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 276
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.904 PM 04/28/2018
(Coding: 16# 2942 017A 0020 0114 0000 0000)


Event 7 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 274
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.904 PM 04/28/2018
(Coding: 16# 2942 017A 0020 0112 0000 0000)


Event 8 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 272
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.904 PM 04/28/2018
(Coding: 16# 2942 017A 0020 0110 0000 0000)


Event 9 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 270
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.904 PM 04/28/2018
(Coding: 16# 2942 017A 0020 010E 0000 0000)


Event 10 of 10: Event ID 16# 2942
I/O access error, reading
P area, word access, Access address: 268
Requested OB: I/O access error OB (OB122)
Priority class: 1
External error, Incoming event
09:59:16.903 PM 04/28/2018
(Coding: 16# 2942 017A 0020 010C 0000 0000)
 
Thank you #sigmadelta, I have ordered for the IM 153-2. Kindly assist on this also . Will I loose the PLC program logic after removing the MMC and restarting the CPU?
 
Will I loose the PLC program logic after removing the MMC and restarting the CPU?
Why do you want to do this?

The IM153-2 is not a CPU, it is a Profibus slave interface module. While it does have an MMC slot, it is not used for operation. You only have to match the DIP switches for the node address on your new IM153-2.
 
Yes, I know IM 153-2 is profibus slave interface but I am asking about something else. While I was troubleshooting my plc I removed the MMC from the CPU and restarted. I want to find out if I will loose the program logic?
 
I am very grateful #sigmadelta for your support. I will keep you posted. Thank you once again!
 
I/O access error (CPU diagnostic buffer), CPU315-2PN/DP

Hello,

I am facing a problem, in my machine, there are 3 FC302 drives, 2 VLT 2800 drives, and IM151 stations, all are connected via Profibus. when I go online in the PLC program, the 2 VLT2800 drives are not connecting in-network while all profi slaves are connecting. I checked the drive profi address and profi cables as well but everything is fine. I checked the PLC CPU diagnostic buffer and I found the below error.

Event ID 16#2943
I/O access error, writing
P area, double-word access, Access address: 708
Requested OB:I/O access error OB (OB122)
Priority class 1:
External error, Incoming event

Anybody can help me how I can fix this problem and how I can find the exact addresses of VLT Drives. I will be really thankful
 
Last edited:
Hassan.

Next time start a new thread.

Look in the HW configuration to find the Profibus station address as well as the IO addresses assigned to the drives.

That several drives are disconnected points to that it is a network problem, not a problem with the drives. Check cabling, connectors, termination switches etc..
What is the topology of the Profibus network ? Are the drives at the end of the network cable ?
 
Dear Jasper,

Thank you so much for your reply. The VLT2800 drives are connected in mid of the network. and I connected the new profi cable and replaced the drives with new one but problem is still.
Could you please guide me how can checked the HW configuration and how can check the IO assigned to drives. Actually I want cross check myself.

Hassan
 

Similar Topics

Hi, I am trying to fix an issue with PV600 standard terminal. After changing one alarm message description and downloading to the terminal, I...
Replies
3
Views
1,498
I have an installation that looks like this https://i.imgur.com/uR7hxki.png , everything works perfectly except for the ET200SP module. I looked...
Replies
3
Views
1,826
Hi all, We are having issues with reading the peripheral inputs of a Keyence SR-1000 barcode reader. Although we already have some experience...
Replies
4
Views
2,941
Not sure what the issue is, there is no security enable on the project and I can download and go online normally. If I hit run to try and trace...
Replies
1
Views
1,776
Hi all. I am working on converting a PV300 to a PV C400. System is using a Micrologix 1500LRP with several expansion IO modules. Communication...
Replies
5
Views
2,068
Back
Top Bottom